0
$\begingroup$

I'm working on an Earth model and when I apply its textures I get them repeating instead of being applied only once. Im still new to Blender, I would appreciate some help enter image description here

$\endgroup$
0
2
$\begingroup$

It seems that your sphere isn't UV-unwrapped. You need to enter edit mode, select all vertices, press "U" on your keyboard and then choose a projection mode that fits your texture. I'd guess that "equirectangular" might be the correct option.

$\endgroup$
0

Not the answer you're looking for? Browse other questions tagged or ask your own question.