1
$\begingroup$

After modelling a character I've unwrapped the model with Smart UV Unwrap and then painted up an image texture. Everything is fine in Rendered View both in Evee and in Cycles but the texture renders crooked as though the unwrap is messed up. I tried loading an older save with the finished model and unwrapping and painting it again with the same end result - the image texture renders crooked and parts of the mesh even loose the Shade Smooth look (see the right wing of the owl).

What am I missing? Have I messed up while modelling?

enter image description here

enter image description here

enter image description here

$\endgroup$
3
  • 1
    $\begingroup$ Hello :). Looks like overlapping geometry. Is it possible that you have an identical mesh only enabled in renders? $\endgroup$ Feb 7, 2021 at 17:57
  • $\begingroup$ Just to add - your 'archive' Collection is only diabled in viewports, not renders, perhaps it's something there :). Related: How to disable an object in render? $\endgroup$ Feb 7, 2021 at 18:31
  • $\begingroup$ Hi! I have a backup copy of the mesh, and I was sure the Archive collection was unchecked, it turns out it was just hidden :D I'm so happy it was just a small dumb thing :) Thanks a lot! $\endgroup$
    – Denis
    Feb 7, 2021 at 18:40

1 Answer 1

1
$\begingroup$

It definitely looks like z-fighting. Likely caused by a copy of the object on top of the one you want to render. You cannot have two surfaces that overlap and use the exact same point in space, the 3D engine will not know how to render that and display one surface or the other randomly.

Check if you don't have a copy of the object. Delete it or disable it for render.

See:

Avoid rendering hidden objects (blender 2.8)

If the mesh is duplicated as part of the same object, then enter edit mode and do Mesh > merge by distance to get rid of duplicated vertices

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .