I created a room (floor, table, walls and windows). For the windows' faces, I used a material with the following features (I list below only the features I changed, the remaining ones kept standard, ie, as they came):

  • Principled BSDF
  • Base color: white
  • Specular: 0.15
  • Roughness: 0
  • IOR: 1.5
  • Transmission: 1
  • Emission strenght: 0

I checked Screen Space Reflection both in materials and in Eevee render.

Finally, I added a reference image with sky and trees to be the outside environment. However, I cannot see the image through the windows (either in material or render mode, independently of rendering in eevee or cycles).

My question is: How to make the windows material transparent so that I can see an image through it?

  • $\begingroup$ Wooow. That works! Thank you! $\endgroup$ – Brasil Feb 5 at 19:04

When using transparency in EEVEE, make sure to set the material's Blend Mode to something other than Opaque. Alpha-Blend or Alpha Hashed should work fine. For some objects, you may also find things look better if you also enable Backface Culling:



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.