2
$\begingroup$

I have some animations and baked simulations in my scene. When I view the playback, it plays at around 16 fps. Right now I can use my mouse to scrub through the timeline which works ok, but obviously I can't move at an exact speed. I know there are ways to improve the fps, but is there a way to simply force 24 fps? I don't care how bad it looks and I don't care if it skips every other frame. I just want to see how the animation looks in real time.

$\endgroup$
1
  • 1
    $\begingroup$ Unfortunately you don't describe your scene, so there is little to go by. The trick is in optimizing playback as much as possible, try solid shading or wireframe, disable subsurf temporarily (or set the number of subdivisions to a lesser number), set the display of particles to a lesser number and physics to a rough subdivision. $\endgroup$
    – susu
    Feb 5, 2021 at 5:20

2 Answers 2

0
$\begingroup$

I randomly found an answer to this while looking for something else completely unrelated.

Settings to make viewport playback drop frames in order to keep up with actual animation speed?

$\endgroup$
-1
$\begingroup$

I can see the problem here. It is probably because your hardware isn't able to handle it. I am sorry to say that. Maybe try restarting your computer, or try clearing any junk files, anything to increase the speed of your computer. If you could share your computer specs, it would be easier, or there is one more solution, try removing 1 simulation. This might boost your computer. It would be easier if you could share a video of the simulation in the viewport mode along with your hardware specs.

Cheers, Aster17

$\endgroup$
8
  • $\begingroup$ I'm running on an intel core i7-8700 with a GeForce GTX 1070 and 16 GB of RAM. If I turn off everything except a simulation I can get 24 fps, but if I try to see the big picture it slows down $\endgroup$
    – caleb lee
    Feb 5, 2021 at 17:58
  • $\begingroup$ Well, then it only means that you have too many simulations, try lowering the number. Are you rendering in cycles or Eevee? If cycles, are you rendering in GPU or CPU? $\endgroup$ Feb 6, 2021 at 3:00
  • $\begingroup$ Cycles, GPU, I know if I remove simulations it will speed up. I was just wondering if there was a way to brute force it like when you drag the cursor along the timeline $\endgroup$
    – caleb lee
    Feb 6, 2021 at 3:04
  • $\begingroup$ Ok, so is it slow while in the viewport mode, or while rendering, or is the rendered video slow ? $\endgroup$ Feb 6, 2021 at 4:14
  • $\begingroup$ Look, if it is slow for some reason in the viewport, or if it is slow while rendering, it isn't a problem. But if the rendered video is 16 fps, then there's an issue. If it is either of the first 2, you shouldn't be worried. Simulations in cycles in the viewport are always slow. You could use Eevee to view the sim in 24 fps. While rendering, the frames will be slow. If it is slow while rendering, then put it in the comments. $\endgroup$ Feb 7, 2021 at 2:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .