I have image sequence that I want to use to control particle spawn area. Image sequence is black and white mask in nature. It depicts a moving disc:

Image sequence applied as texture in the material node editor

When I try to use the same sequence to control particle spawn with the "Density" controller, I get very wacky results. They seem fine in viewport as you will se in the gif below, but in render results are wrong.

Viewport display, seems fine

Render of the same scene, does not look like a viewport result

Render result

Here I made a gif of my process (20mb): https://drive.google.com/file/d/1-GA9eF6biSXK4Nv2on2QecZgIRAdwrOS/view?usp=sharing

So how do I control particle spawn with the image sequence the right way?

Unfortunately blender can't pack image sequences in to file, so i put my blend file and image sequence here: (1.3mb total) https://drive.google.com/drive/folders/1CcxzUDwEFGFghC-nYHWwr8zidshfLb7y?usp=sharing

  • $\begingroup$ is it necessary that it is an image sequence? Because what you show here you could easily recreate with a flag cylinder and animate that.... $\endgroup$
    – Chris
    Feb 4, 2021 at 18:36
  • $\begingroup$ Yes, this scene is just a test for more complex effect where i would need to emit particles from black and white (mask in nature) image sequence. More to that, i want to to know why this relatively simple setup does not function. Is it a bug or what is the reason for it. What is a flag cylinder by the way? Out of curiosity. $\endgroup$ Feb 4, 2021 at 18:44
  • $\begingroup$ Sorry, that’s a typo. I meant flat cylinder 🙈 $\endgroup$
    – Chris
    Feb 4, 2021 at 18:50
  • $\begingroup$ Have you tried baking the particles? $\endgroup$ Feb 4, 2021 at 20:13
  • $\begingroup$ Are you talking about "Cache" in particle tab? Yes, you can see it in the big 20 mb gif that i posted in the question. In fact baking them makes situation even worse, result may become even jankier. $\endgroup$ Feb 4, 2021 at 20:33

1 Answer 1


You are lucky more than me :) I got particles emitted only from a one frame (tested with 2.79, 2.83, 2.93 and according to this answer and its link to devs (also seen as closed bug report with this topic in 2017) ... seems like limitation persists. So what you see in your preview is a pure love of God :)

So ... seems like the only one option to control animation with texture is to translate animation into a gradient image.


  • To prevent release from black pixels I used image with transparency (PNGA). For some weird reason I had to set Alpha > None to let it work as intended.
  • To get a bit of randomness of release apply a Noise filter on image


I know you said your example is just a prove of concept, but probably you would be able reuse for your needs as well.

  • $\begingroup$ Thank you for your effort. I will try this approach later. Do you think this situation we experience is a bug? For me it does not look like Blender working correctly here. $\endgroup$ Feb 5, 2021 at 13:33
  • $\begingroup$ I found this issue on BugTracker - 2013, 2015, 2017 ... always closed as invalid report. For all years devs say it is a "current limitation". I can understand to this, but if so ... it should be simply restricted from User Interface to avoid confusion. $\endgroup$
    – vklidu
    Feb 5, 2021 at 15:32
  • $\begingroup$ In the link I provided in my answer, there is mentioned this report developer.blender.org/T28212 explaining the "thing". Also mentioned pending patch ... but as you can see it was moved to TODO list already in 2011 :) So ... long run :) And since all community is waiting for Particle nodes I don't thing it would be tackled. Maybe you would be more lucky with Animation Nodes. $\endgroup$
    – vklidu
    Feb 5, 2021 at 15:46
  • $\begingroup$ So I tried my best ... devtalk.blender.org/t/… $\endgroup$
    – vklidu
    Feb 5, 2021 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.