0
$\begingroup$

Newbie to Blender here. I'm trying to render an interior scene - it's a very simple gallery with two windows. I have added an Image Texture to the 'floor' - this is supposed to be a mid-dark brown wood texture. There are a number of lights in the room, as well as a light outside the windows. (I will attach pictures and the .blend file). In Viewport Shading, the room looks exactly how I need it to look - the colours are saturated and the lights look ok. However, when I go to render it, the floor texture becomes entirely washed out and grey. I have changed the world background colour, I have tried to see if the colours are desaturated, I have changed the image texture to be in the sRGB space - nothing seems to work. I also made a backup and removed all the lighting, and put one spot in the middle of the room to test if my lighting was the issue, and the problem persisted.

I imagine that there's something in the render settings that isn't quite right, but I can't figure out what it is.

Here is a google drive with the relevant pictures and .blend file.

https://drive.google.com/drive/folders/1SfXgCVzyjKCa4T7CZW_Y_u9V0HuZLg4p?usp=sharing

Hope you can help!

$\endgroup$
1
  • 2
    $\begingroup$ A quick tip: You can upload and add the images directly to your question so that people can see at a glance what it's all about. It may be just an extra click, but when you go through 20 questions, it gets annoying ;-) $\endgroup$
    – Blunder
    Feb 3 at 16:27
2
$\begingroup$

There is object "Plane" in a Collection "FloorPlan" which is hidden in viewport ("closed eye" symbol) but it's still rendered. So it overlaps the floor and causes the glitch in the final render.

In Blender 2.8x, the nasty thing is that objects in a collapsed collection, are still rendered. You need explicitly disabled them (or the collection) for render ("camera" icon). The toggle is not shown by default. You need to activate it in the filter settings of the outliner.

hide for render gif

In Blender 2.9x, the checkbox of the collection collapses and inactivates the collection. Then everything inside of the collection is automatically hidden, in viewport and render.

$\endgroup$
1
  • $\begingroup$ Thank you so much! That's excellent :) $\endgroup$
    – luca.vitas
    Feb 4 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.