3
$\begingroup$

I have a view layer. A few collections have holdout enabled, as I wish to mask out the area they occupy. However, freestyle outlines sections that shouldn't be visible

Essentially, if I have the setup with the two cubes, with one with holdout enabled, Blender Setup

How do I prevent the masked segments from having lines? Render result

$\endgroup$
1
$\begingroup$

This is a known limitation: freestyle not influenced by holdout collections.

If you set Holdout as shader material to an object, it works:

Except, one line is missing. This is because majority of the line is hidden. If majority was in front, the entire line would be visible (well, unless the line is cut by another line):

This is also a limitation of Freestyle: Freestyle with occluded objects - freestyle lines bleed into hidden regions. The solution is increasing the geometry (effectively dividing the line into many segments).

If there's too many objects to go for that, you can create a new View Layer, in old View layer disable the holdout collection by clicking on the check-mark icon , while in new layer make the base collection (the one that should be visible), as the holdout layer. This way on the 2nd view layer what's visible is what you want to cut from the first view layer, which you set in a compositor like this:

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.