1
$\begingroup$

It took me a while to move over to the new Blender version. Got my hotkeys changed and activated my favorite plugins. What I noticed is with relatively low poly objects (100k) the edit mode is incredibly slow and unresponsive compared to blender 2.79.

Just grabbing a vertex and moving it feels sluggish, selecting also. When grabbing a few (10) vertices and moving them around continuously my cpu is between 15-30% and response is quite slow. Doing the same in 2.79 it is fast and cpu sits around a comfortably 2-5%. The graphics card is idling at 20+/-Mhz and only increases in speed (2500+) when I move around in the viewport.

For the same operation Blender 2.91 uses 10 cores at 100% compared to 1 or 2 cores in Blender 2.79.

I also tried the same things without any plugins active (deleted my user profile). Turning of AA does nothing, but that is to be expected since that only increases the GPU load. I don't have any modifiers active on the model. Turning on a simple subsurf (resolution 1) in 2.91 increases my ram usages to 18GB with only 750k vertices compared to Blender 2.79 where it goes from perhaps 400MB to 600MB.

What could I change to get a more responsive Blender, as it is now I can't consider 2.91 to work with; it seems horribly broken.

My system is:

  • R9 3950x stock
  • AMD RX 6900 XT stock
  • 32G 3600 c15 memory
  • Windows 10 Pro, probably latest update as of now.

Edit 3 Also tested it on my old (and slow) laptop

  • i7 6700HQ
  • Nvidia 960M
  • 16GB memory
  • Windows 10 Pro latest updates

Small edit: the performance while not editing, like moving the view in the viewport is very fluid and not a problem.

Another edit: Things like limited dissolve are a magnitude faster in Blender 2.79. I think that the developers of Blender should first focus on getting reasonable performance (increase it by a minimum of 10 and decrease memory usage by the same amount) before it is anywhere usable. I think doing some minimal research on time complexities of algorithms might solve a lot of their problems https://en.wikipedia.org/wiki/Time_complexity#Table_of_common_time_complexities

Something tells me it has something to do with that.

I'll stick with the old Blender for now for cleaning up models before printing...

Just to note, sculpting is lightning fast; at this point I'm clueless why normal editing is so slow.

$\endgroup$
4
  • $\begingroup$ What rendering engine are you using in 2.79 (Blender internal or Cycles), and what renderer are you using in 2.91 (Cycles or EEVEE)? $\endgroup$ Feb 1 at 21:57
  • $\begingroup$ In 2.79 it is Blender Internal, in the viewport and in 2.91 I could only find the option in render properties and it is set to EEVEE. However, I'm not doing any rendering. I only use wireframe and solid. Switching to Workbench does not improve the problems I describe since moving the view in the viewport I probably get more than enough fps. I only use Blender for cleaning up models for 3d printing nowadays. $\endgroup$ Feb 2 at 19:55
  • $\begingroup$ An issue with the AMD card most likely. Upgrade or downgrade the drivers. $\endgroup$
    – susu
    Feb 6 at 23:50
  • $\begingroup$ Which thing I describe make you think it points to an driver issue? The problem I have is at the previous and latest driver (there aren't any others for this card since it just came out). Everything is fast (navigating the scene with 20mil vertices is no problem) except moving vertices around or some mesh operations like subsurf and limited dissolve, which clearly is not any work the gpu is really bothered with. Btw I also tested it on my older Dell laptop i7 6700HQ and 960M and I experience the same problems so it is clearly not a gpu driver related problem. $\endgroup$ Feb 8 at 13:09
0
$\begingroup$

I have the same problem but I'm using 3.0 and it happened while I was working on a project mid scene. I did two things. Started using Matcap shader for the first time. I also installed AMD Prorender. I'm going try uninstalling those 2 items and if that doesn't work I'll try upgrading the gpu drivers. Thanks for this thread as it's so frustrating as there's only 34K verts in my scene. Happens when I try editing/moving verts/edges. Painfully slow. This is my first major scene/time spent on Blender and if this happens at this stage it's really crushing after all that work. Hopefully it's a bug that can be rectified

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.