1
$\begingroup$

Currently I'm rendering on cpu, because at the time of writing it's faster for me (tested it a few times).
I know this is kind of bad and I should get a better gpu, but well, currently it's not possible to buy the 3080 that I want.

So I'm stuck with rendering on my Ryzen 9 5900X instead on my GTX 1060 (I know that this card is a bottleneck for me).

Also to notice, I'm pretty new to blender. But what I noticed while rendering on CPU is, that the Intel Denoiser is applied after a tile got rendered. But only with a single core.

Maybe this isn't such big of a problem when I render on GPU, because in the meantime the CPU can put all it's power into denoising.

But is there a way to let this run multithreadded?

For example my remaining render time at the beginning was 20min, and round about this time it was finished. But now it's denoising (40min in) and I would say it's just 2/3 finished. So it would totally take 60 instad of 20min for my render. Is it because I don't have an Intel CPU?

Maybe somebody could assist me with this.

Thank you very much

Here you can see that 23 threads are rendering the image and 1 thread (tile) is denoising. enter image description here

$\endgroup$
9
  • $\begingroup$ Which denoiser have you activated? (blender.stackexchange.com/questions/178257/…) You mentioned the "Intel denoise" but have a Ryzen CPU? The 'Intel OpenImageDenoise' requires an Intel CPU. When you enable denoise in the Cycles options then only 1 thread (tile) is used for denoising. When you have a Interl CPU then you can use the compositor node setup with the denoise node and the whole image is processed at once. $\endgroup$ – Blunder Jan 31 at 20:31
  • $\begingroup$ I got the OpenImageDenoise activated. And I was wondering why it‘s working because yeah, it‘s not an Intel CPU. What should I use for good denoising with AMD? $\endgroup$ – jona Feb 1 at 8:19
  • 1
    $\begingroup$ @Blunder OIDN doesn't require an Intel CPU. You can either use the denoise node or enable it in Render Properties > Sampling > Denoising > Render. $\endgroup$ – Robert Gützkow Feb 1 at 17:40
  • $\begingroup$ @RobertGützkow I just enabled it where you said. Is that a disadvantage over the node? I tested it again today. After 30min the render was completed, time remaining was on 7min (didn't go down) and it took 45min more to denoise, because only one tile was used for denoising. $\endgroup$ – jona Feb 1 at 19:18
  • $\begingroup$ @RobertGützkow oh, you're right. I confused it. The CPU must support SSE4.1, Ryzen CPUs do this. $\endgroup$ – Blunder Feb 1 at 23:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.