1
$\begingroup$

Looking through past posts I see this problem has been addressed often. I have tried many of the offered solutions unsuccessfully. I have a hi poly sculpt that I have normal mapped to a lower poly object. I would like to see the effect of that normal map while painting in a diffuse color slot in texture paint mode. The map looks fine while in the render viewport setting but does not show up in any other viewport setting. Painting while in a render viewport is too slow and not a viable option. To check my basic settings I made a simple scene with a plane object normal mapped with a sculpt and was able to see the mapped result fine in texture paint solid or texture viewport. So it seems the process does work but I cannot get it to work on this particular file. Is there a poly count limitation at work here or am I totally missing something obvious? Please see attached images demonstrating this issue.normal map as seen in tex paint

normal map not affecting view

normal map effect visible in render view

$\endgroup$
  • $\begingroup$ Thanks for the answer MarcClintDion. Unfortunately this does not resolve the problem. As stated in my question the texture shading viewport setting does not change the appearance of the model. Although it does fine with a simple file. $\endgroup$ – BenK Dec 17 '14 at 15:50
  • $\begingroup$ The solution was quite simple but hard to discover. It wound up that the draw settings in object properties was set to solid and not texture, therefore while in glsl texture view mode the normal map texture is not visible. $\endgroup$ – BenK Dec 19 '14 at 2:47
2
$\begingroup$

Textured shaded mode may be what you are looking for. It's shown in the animated image below. Sorry about the messy .gif. Apparently LiceCap really does not like Texture Painting.

To use this viewport shading mode with normal maps, you should add some lighting or all you will see is a sold black model.

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.