0
$\begingroup$

I animated my scene before realising I wanted it at a higher framerate. Oops! Rookie mistake.

So I enabled time remapping and stretched it out to twice the duration (from 100 frames to 200 frames). Everything interpolated smoothly, except for my cloth simulation. That made sense since I baked it before time remapping, and I could see it only generated 100 .bphys frames to disk.

So I deleted my bake, set the simulation speed to half, and baked it again. I could see it generated 200 .bphys files this time, so I thought it was fixed. But when I scrubbed through the timeline frame-by-frame, I could see that it was just repeating the same frames twice (instead of properly interpolating the in-between motion). So while everything else was running at 50fps, my cloth simulation still appeared to be going at 25fps.

I've decided to just stretch the keyframes out on my dopesheet instead of using time remapping for the time being, but I just wanted to know if anybody else has encountered this and can offer a solution? It would save me a lot of headaches in the future.

$\endgroup$
0
1
$\begingroup$

So ... if I'm right, cloth sim doesn't have subframes (substeps) and I don't see any interpolation to solve those jumps (smooth missing transitions).

As a workaround you can try export the cloth sim object as Alembic (.abc) format without time-remapping. Under Output Properties > Dimension > Time Remapping set New > 200. Import this object back and under Modifiers Properties you can find already added Mesh Sequence Cache modifier > enable Vertex Interpolation. It will generate smooth transition between ramped time frames.

enter image description here

$\endgroup$
2
  • $\begingroup$ Massive thanks! I'm still new to Blender so I never knew about this modifier. This will help me out in the future. $\endgroup$ – Ben M Jan 30 at 23:51
  • $\begingroup$ If answer solved your issue consider mark answer as accepted so other can see it from main list and system is not pocking Q in period. Thank you keep site organised. blender.stackexchange.com/tour $\endgroup$ – vklidu Feb 3 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.