I am not sure if this is a bug or a wrong setting. I have quite a big scene with a bunch of textures, therefore in the Preferences I set the Texture Size Limit for the Viewport to 1024px. Otherwise the scene wouldn't work properly on my hardware setup.

Now when I do a render, the render result is pixelated, I would assume it's scaled down to the Size Limit of 1024px. When I turn Texture Size Limit off, it's shown in full resolution.

Since it is not very convenient to change the Size Limit all the time, has anybody encountered this problem and knows a solution or a workaround?

Working with Blender 2.91 for MacOS

  • 1
    $\begingroup$ Hello :). Cycles also has a Simplify option in render settings, perhaps that would work better? $\endgroup$ Jan 29, 2021 at 16:54

1 Answer 1


Yes, it seems to be a fork :)

  • On one hand you would probably expect to see final render in a full res.
  • On other hand it make a sense keep lowers across whole app for its consistency.

You can say OK - lets use "limit size" only for external images, but that rule doesn't make things work better since you can "pack" images into a blend file.

Also your render is not always the last operation in blender. Image editor, Compositor, VSE, with viewers and previewing options ... all of these editors can continue in editing of this render too. So also here user still could benefit from "limited size". By other words - render starts to play a roll of a "texture". So I guess it is not an easy task to decide where to use limited and where to keep full size texture.

But it's just my theory, probably there is a simple solution behind a lot of my words :)


Try "Auto Save" add-on that saves render automatically, so you can just switch to folder and preview (view) your saved render ... similar step to switch to blender's image editor to check result.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .