1
$\begingroup$

I turn to you with a question about Blender (2.90) rendering behaviour.

I am rendering a colored plane only (literally, that's it - no shading, plugging the "image texture" node right into the surface node of material output), so quite a simple setup. However, when rendering the plane, Blender creates some weirdly colored pixels at some locations on the plane's borders (see image). Note that these are not visible in the viewport and only show after rendering.

I am rendering with Cycles, transparent RGBA, to 16bit png. I already tried setting Film -> Pixel Filter -> Gaussian to the smallest size possible (0.01px, I need to render it without Anti-Aliasing), and also set "Alpha Clip" in the material section. I experimented with Eevee and also with different render resolutions (ranging from 250p to 1080p), alas to no avail. I tried setting the backside of the plane to another color, but that didn't help either. I also tried setting the number of samples in both viewport and renderer to 1, which didn't help either.

Full plane:

enter image description here

Artefacts (zoomed):

enter image description here

Does somebody have an idea what is going on here? Any hints appreciated!

and the texture that is applied to the plane: https://imgur.com/aldZWyX

$\endgroup$
4
  • $\begingroup$ Untested, but it looks alpha premult. Note that you're getting antialiasing if you're using more than 1 sample for your renders, so you might consider setting samples to 1. $\endgroup$
    – Nathan
    Jan 29 at 17:59
  • $\begingroup$ Please attach your simplified blend file to see your setup. Use blend-exchange.giantcowfilms.com and paste given code into your question. $\endgroup$
    – vklidu
    Jan 29 at 18:17
  • $\begingroup$ Thanks guys, Nathan: I tried rendering with 1 sample already, same results. @vklidu: I have updated the question with the .blend file and the texture that is applied to the plane. There's also a script that renders the image from the viewpoint above, clearly showing the artefacts. $\endgroup$
    – i2n
    Jan 30 at 9:18
  • $\begingroup$ I suppose lights in the scene are not relevant to result (also script gave me an error). One note - texture like this is better "packed" into blend file. Since links are not permanent. This site is maintained to be knowledge base, so others can find answers for their issues. Thank you $\endgroup$
    – vklidu
    Jan 30 at 9:49
2
$\begingroup$

Because you are using Repeat extrapolation in Image Node.
Those pixels are just texture's pixels from opposite side of texture.
Set Extend instead.

enter image description here

$\endgroup$
2
  • $\begingroup$ Yes, that indeed solved the problem. Such a small setting, causing such havoc. Thank you very much! $\endgroup$
    – i2n
    Jan 30 at 9:36
  • $\begingroup$ You are welcome :) I know, we all have those ... :) $\endgroup$
    – vklidu
    Jan 30 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.