0
$\begingroup$

(blendfile attached : https://drive.google.com/file/d/1DwS8ZN3pF6nQY0i9CgwZgsIfeeG0TcSD/view?usp=sharing )

My hair is very buggy.

I have a hairstyle composed of two layers, two particle system, one for the main hairs, and one for the frizzy hairs. The scalp where the hair is, has modifiers set up like this :

image

And here is a picture of the hair how I want em, and how I stylized em in the particle editor :

image

But this is how it looks when I disable the fluid modifier that the scalp has

Screenshot 2021-01-29 013058
Screenshot 2021-01-29 013058
528×510 67.7 KB

And this is how it looks when I uncheck the “Dynamic Hair” box

Screenshot 2021-01-29 013121

I want to simulate my hair, but when I bake it, it comes out weird and deformed, plus, the main hair are static, there is only the frizz going crazy.

I want to simulate hair correctly, looking exactly like the first picture, but without the fluid modifier, wich I think is causing problem in the sim.

(blendfile attached : https://drive.google.com/file/d/1DwS8ZN3pF6nQY0i9CgwZgsIfeeG0TcSD/view?usp=sharing )

Edit : If you wanna see the particles in edit particle mode, make sure this option is set to particles :

enter image description here

$\endgroup$
8
  • $\begingroup$ Your question is very detailed. But why is there a fluid system on the head? $\endgroup$ – Blunder Jan 29 at 12:45
  • $\begingroup$ Well no reason, It's a mistake, I wanna remove it $\endgroup$ – Aplogn Jan 29 at 13:07
  • $\begingroup$ Ok, and why not just remove it? Sorry, I have to ask because it's not clear what the problem is. When you remove the unnecessary fluid then the fizz hair will be moved and look different. Ok. But it's not a heavy combed hairstyle, is it? And you want to animate it and it has Hair Dynamics enabled? So why don't delete the edit of the hair, add some hair particles again and let the Hair Dynamics do its job? $\endgroup$ – Blunder Jan 29 at 13:30
  • $\begingroup$ Well everything is changed when the fluid modifier is removed check the images above, especially on the bottom right of the image you can se the hair is way longer + even If I do that my hair doesn't simulate properly, but you can test is, just bake 3-2 frames and you'll see immediatly it doesn't work. Also, might I ask you to put an upvote in order to make my issue known by more people ? $\endgroup$ – Aplogn Jan 29 at 13:36
  • $\begingroup$ Oh, ok. You're right, it changes also the main hairs. It's probably because the fluid modifier alters the mesh data. The particle systems are below the fluid modifier on the stack. You should edit your question that you want to get rid of the fluid modifier without breaking the combed main hairs $\endgroup$ – Blunder Jan 29 at 13:50
1
$\begingroup$

Ok. You have Fluid modifiers everywhere! On the Scalp, on the Body and, on the (hidden) Hat object. (How did that happen?)

Here is a fix list ;-)

  1. Remove the Fluid modifiers from the objects
  2. When you remove the Fluid modifier from the Scalp object then the main hair will be modified (2nd picture of the model in the question). There is a long "children" strand on the left side of the head, far away from the hair particle (hair guide). The reason for this is that [X] Long Hair is ticked in the Hair Particle Settings for the Interpolated Children. Turn off Long Hair for the children. Then the children will follow closely the hair guides and the hairstyle will look like before.
  3. If you make the main hair static by turning off Hair Dynamics the hair will change and look like in picture 3. This is because there is a Collection named "SCALP" set in the Hair System Settings → Field Settings → Effector Collection. Clear the value here and the hair will look fine again.

Side notes:

  • I've tried to run your hair simulation but when I press the Play button the frame jumps 1, 30, 70, 123, ..? I have no idea what's going on there. If I move the fixed Scalp object into a new blend file the hair animation works fine and the tips of the 'Fizz' hair move slightly.
  • The 'Body' has a Subdivision modifier, level 3 for viewport and render. This results in 280k faces and 500k tris. Maybe turn it down to 1 and 2? There is no difference between level 2 and 3 except for the 200k extra faces (70k -> 280k).
$\endgroup$
2
  • $\begingroup$ Thanks. No I can assure you I can't uncheck the long hair particles, as the hair won't look the same as the same picture, it looks similar yes, but not the same. For the force field collection, it's because somehow it affects the look of the hair even when dynamics are turned off, it might be a bug. I reduced the force of these force field and the problem was gone, I also make sure to delete the cache file manually before every simulation, and it resolve the problem of my particle going nuts when simulated. Still, my hair are sometimes intersecting with the hat, how to solve that ? $\endgroup$ – Aplogn Jan 31 at 11:58
  • $\begingroup$ Also the cache steps must be set to 1. $\endgroup$ – Aplogn Jan 31 at 12:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.