5
$\begingroup$

I have a scene with objects and lighting, and all the objects have textures/shadows/etc... baked via cycles. For example, the ground plane texture:

enter image description here

Now I can set all the objects with their baked textures as shadeless and they look fine.

enter image description here

But I can't get the player object to cast shadows (using the same spot light).

enter image description here

I understand shadeless essentially turns off shadows, but I need some way to turn off all shadows except shadows emitted by the player object. Is there a way to do that? I am trying to achieve real time shadows from a player in a baked environment. Seems like it should be possible?

I've tried a ton of the checkboxes and sliders in the materials panel (like Shadows Only and Alpha Blend) but to no avail.

$\endgroup$
  • $\begingroup$ Okay, in the opengl, turn OFF shadeless. Then, use the "emit" field or texture plug in slot to apply your texture. Lets see what happens then! $\endgroup$ – beiller Dec 18 '14 at 19:11
  • 1
    $\begingroup$ Could you post a .blend file for us to test with (texture packed in), it helps us to figure out a solution. $\endgroup$ – GiantCowFilms Dec 19 '14 at 11:46
  • $\begingroup$ pasteall.org/blend/33423 $\endgroup$ – Entity Dec 19 '14 at 17:37
2
$\begingroup$

objects that needs to receive shadows (ground or other objects) can't be shadeless. They need a material with shadow/receive (and/or receive transparent) box checked. Objects with baked shadows (monkey and icosphere) can have their cast, cast only, cast buffer shadows and cast approximative boxes unchecked. They won't cast shadows on the player (or anything) but it's not a real problem i guess.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.