2
$\begingroup$

At the right hand side of the Blender UI there is a collection manager that lists all objects, lights, cameras, etc in the scene with their respective collections. Every single object is disabled, how do I re-enable them all at once?

$\endgroup$
2
$\begingroup$

There may be a better way? But here goes..

In the (funnel) 'Filter' dropdown of the outliner, enable the 'Disable Selection' dart-icon, if you haven't already.

If there is a top-level collection, below 'Scene', containing all the others, Shift-click the dart icon next to it, to recursively set the 'Selectable' state of all the collections and objects beneath it.

If there is no top-level collection, you can temporarily or permanently create one.

  • ShiftA once or twice to collapse the Outliner view and make it easier to see what you're doing.

  • Right-click below 'Scene' to create and name a new top-level empty collection.

  • Select all the top-level collections and objects whose state you want to change, drag them over the new collection and Ctrl-drop them there. This will link everything to the new collection without disturbing the originals.

  • Shift-click the dart next to the new collection.

Once done, you can X delete the new collection of links, if you want to.

There is also the per-viewport 'View Object Types'setting in the 3D-View header to look out for, if objects are unselectable.

$\endgroup$
2
  • $\begingroup$ This is definitely a most needed one-click feature ! You can also create a new View Layer, which will toggle every collection on, but there is so many downsides I wouldn't even consider it :) $\endgroup$ – Gorgious Jan 27 at 9:34
  • $\begingroup$ @Gorgious I think there's a real grammatical problem in this part of the interface. The distinction/equivalence between 'selected' in the outliner and 'selected' in the viewport is not clear. Disabling selection in the viewport should not disable selection in the outliner, for the purposes of changing the 'selectable', or any other property, there. $\endgroup$ – Robin Betts Jan 27 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.