1
$\begingroup$

After importing a .fbx sofa model I found online, I realized the scale was set to 0.001 so I applied the scale (Ctrl + A, S) to set it to 1 but my image texture is still far too big to display properly. I've tried scaling my image down through the mapping nodes but I can not get it to work. I checked the UV editor and the mesh on the sofa is so tiny that it's impossible to even see on my screen. How do I get this to scale properly? I've added a plane in the scene to demonstrate what the image texture should look like and how I normally apply my textures.

enter image description here

Here is a link to the .blend file

$\endgroup$
1
  • $\begingroup$ Does your object have a UV map? Can you add an image that shows it? $\endgroup$ – susu Jan 26 at 20:11
2
$\begingroup$

The problem is that there are 2 UV maps ("UV_Channel_1" and "...2") but they are empty (or broken). empty UV maps

To fix them delete the UV maps and create new UV maps for all parts of the couch. With the mouse in the 3D viewport and in Edit Mode, press U for unwrap menu, then select "Smart UV Project" from the menu, and you will have a working UV map.

new UV map example

(The bottom part of the couch needs some manual adjustments in the UV editor or scaling.)

Last but not least: In the render settings, under Color Management, set View Transform to "Filmic" to get a natural look of the light/exposure. You can set the Look to "High contrast" if you want to have richer colors. (And of course, add some more lights to your scene ;-)

color management

$\endgroup$
1
  • $\begingroup$ thank you very much for the explanation! That all makes sense to me now. $\endgroup$ – JOHN GREENAWALT Jan 26 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.