0
$\begingroup$

I have several plane objects on top of each other, but they all clip behind the largest one, which is supposed to be under all of them. I thought this is only viewport issue, but when I render, they are either hidden or clipping. So this is not about setting clipping distance. I thought it is because I have them separated only by 0,002 distance, but even when I scale the scene up it does the same thing. Some angles are OK, but in some angles it clips completely.

Its been a long day of blender not cooperating, I even had to reinstall. I just cant spend another 5 hours figuring this out on my own.

Hopefully someone will be smarter than me. Thanks.

EDIT: Well that was random. I turned blend mode of the largest object to opaque and it stopped the clipping. Still not great though - I need Alpha for the other planes. Currently they dont clip much, but that will probably change when I add the rest of the layers...

EDIT2: Knowing that the issue is with Alpha, I tried playing with those settings. Changing to Alpha Hashed seems to fix the issue. Still, would like to know if there is any way to make it work with Alpha Blend?

$\endgroup$
1
  • $\begingroup$ @susu thanks for the answer, I tried that and it didnt work. I even increased the distance between planes 20 times and It was still happening. As for the explanation - I thought my explanation was enough, and an image would not be able to explain anyway. The images in your answer are NOT what is happening to me. My clipping is only hapenning when moving the camera/viewport (I cant capture that in still image). $\endgroup$
    – Vernum
    Jan 25, 2021 at 23:22

1 Answer 1

0
$\begingroup$

Looks like you can fix it in Alpha Blend by just applying all transforms on your objects.

So for each object:

  • select the object in Object Mode
  • go to Object > Apply > All Transforms or hit ⎈ CtrlA > All Transforms
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .