1
$\begingroup$

"Animate that property in VSE" seems to be straightforward advice I read frequently, but it does not work for me. In particular I try to animate the opacity of a scene strip and it does not work. I tried with other properties and strip types and it's all the same. What am I doing wrong?

I'm using Blender v2.83.11 on Linux. I experimented and searched a lot and it gives me headache. Not sure whether this is a bug, I think it the wrong way, or I missed a checkbox somewhere. Thanks.

[Update] This seems to be related to Blender's UI and not to the final animation renders. After updating to Blender v2.9x I can produce the desired results (I thought this was not the case for my Blender v2.83). However, the previews still don't work as expected, which makes it difficult to work with (and is a bit annoying), hence I'll leave this issue open for now. Thanks to @wilks for helping here!

Steps to reproduce

  1. Open a new file.
  2. In the default scene for the default cube, set a keyframe for location, switch to a later frame, move cube, set keyframe for location. [step not strictly necessary, but good for checking some things are working]
  3. Create a new scene.
  4. In the video sequencer, add a new scene strip, choose the default scene.
  5. For the scene strip, set a keyframe of value 1.0 for opacity, switch to a later frame, set a keyframe of value 0.0 for opacity.
  6. Scrub through timeline and watch video preview.

Expected vs. actual result

  • Expected result: Smooth fading out of scene strip between the chosen keyframes.
  • Actual result: In all frames the scene strip maintains the opacity entered last.

Other observations

  • In the graph editor I see the keyframes reflected correctly, the graph looks as expected.
  • During experiments I discovered that I can get the expected result in a way that does not really help.
    • Steps to reproduce: Push the keyframe animation into a NLA block/action strip and "Start Tweaking Strip Actions" (TAB when selected).
    • Remarks: The tweaking state is probably intended as temporary mode, so this is not even a workaround. However, this shows that Blender is technically able to do what I hope it could do.
  • [Update] After closing and reopening the file, it works, briefly. I can scrub through the timeline and see the opacity change. However, when I change some way how things are displayed (not even edit something), like switching to edit mode and back again (pressing TAB twice), things are as described above again.

Related questions

  1. Is it possible to animate the opacity of a grease pencil layer?
    • Seems like pretty much the same issue, however there it is claimed that my issue was a bug that should be fixed by now.
$\endgroup$
6
  • 1
    $\begingroup$ DId you try with 2.9x? I used to have that bug with all strip animations, but not anymore. I just checked with 2.82 and it works fine as well. $\endgroup$ – wilks Jan 25 at 15:56
  • $\begingroup$ Not yet. On my version of Linux (Gentoo) Blender 2.9x didn't install (compilation failed) and I stopped putting in more effort. Will give it another chance. $\endgroup$ – creativecoding Jan 25 at 16:42
  • $\begingroup$ Right, I've never tried to compile it myself, I just get the builds from here. Hope it works out, good luck $\endgroup$ – wilks Jan 25 at 17:16
  • 1
    $\begingroup$ hmm, that is weird. Back when I had the bug it was just in preview, the renders were actually fine. Still a pain but worth checking. $\endgroup$ – wilks Jan 26 at 13:41
  • 1
    $\begingroup$ @wilks Good point! The bad preview discouraged me from rendering in this updated version of Blender, but rendering the animation seems to work. I thought this was not the case of the old version, but I might be wrong there. In any case, this seems to be a problem with Blender's UI then, i.e. previews that are not updating. Will check the caching-related settings (again). Thank you for pointing that out! $\endgroup$ – creativecoding Jan 26 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.