0
$\begingroup$

When I try baking an Ambient Occlusion map from multires modifier, the Bake Type option "Ambient Occlusion" is not given, only when the box is unchecked:

enter image description here

To remedy this, I duplicated my multires-object, applied the modifier on the duplicated mesh and just baked it with ambient occlusion as bake type (with "Bake from Multires" unchecked of course). I made sure the original model that still has the multires modifier NOT applied to it is hidden in rendering, but the ambient occlusion map is almost entirely black when baking is done. enter image description here

I then tried a different workflow, selecting high poly first, then low poly (with multires entirely removed in case it causes issues), then checked "Selected to Active" and hit bake. It's always the same result, it's always black: enter image description here

I checked the normals: They're all good. I tried checking the Ambient Occlusion box under world settings. I've experimented with ray distance ranging from 0 to 0.00005. And on a side note, a few new white dots appeared on the still mostly black texture at 0.00005, but I have no idea how far to go for it to do something since 0 changes nothing, and overall this still feels wrong since it's way too dark: enter image description here

I really don't know how to solve this. What could be causing this issue?

$\endgroup$

1 Answer 1

6
$\begingroup$

To this day I don't know exactly what that checkbox "Bake from Multires" does. I had once read that it was a relic from old times (Blender 2.79 and older)...?

Anyway, you can bake the AO in a different way, with the Ambient Occlusion Node, and then bake it as "Emit".

Baking Preparation:

  1. Switch to Cycles, under Color Management, set View Transformation to "Standard" (to get a map with pure colors.)

  2. In the Shading editor, switch to "World" and set the background color to pure white (#FFFFFF). That's the light for the AO map.

  3. Turn off any other lights in the scene and make sure you render only the objects for that you want to bake the AO map. ("Camera" icon in the outliner.)

world bg color

Baking:

  1. Select the material of the object's that you want to bake. In the node editor, add an Ambient Occlusion node, and a Color Ramp and plug that in an Emitter node, and that into the material output. Adjust the Color ramp to get the desired shading of the AO map.
  2. Add an Image Texture node and select it (= image for the baking result)

AO node setup

  1. In Cycles, under Bake, chose Bake type "Emit", leave "Bake from Multires" unchecked
  2. Check the render settings, select the object, and hit bake!

bake options

Clean up:

  1. Save the baked image
  2. in Color Management, set View Transformation back to "Filmic"
  3. Restore the light setup (World background, Lights)
  4. Turn on, the rendering for the objects you want.
$\endgroup$
1
  • $\begingroup$ If I set the Baked AO image as in the screenshot, I get an error when baking. This is fixed by leaving it on "Generated" instead of setting it to "Single Image". $\endgroup$
    – Oogst
    Sep 29, 2021 at 8:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .