1
$\begingroup$

Node set up I think this must be some simple thing that I have missed, but I can't get this model to render properly in Cycles, yet it works perfectly in Eevee. The cycles version is not rendering with any shadows or texture. I'm stumped. The textures are jpeg - I am wondering if that might be it?

This is bound to be some simple thing - does anyone know what it could be?

Cycles left - Eevee Right

$\endgroup$
5
  • $\begingroup$ Hi Susu, thanks for the response. I will do as you suggest later today, however the shaders were set up in a "standard" way, and its the CYCLES version which is not responding to light - ie as if the images were emitting. The Eevee version is the one on the right. The model has image textures for colour, metallic, normal, and an alpha. Importing the shaders, the alpha from the image shader was plugged to the alpha of the BSDF, where it should have been the colour. Disconnecting had no effect on whether cycles shaded the model or not. $\endgroup$ Jan 25 at 9:22
  • $\begingroup$ As per susu's request here is the node set up. This is pretty much how it came with the FBX. The only thing is I tried converting the jpg to png and re-importing the image for the texture colour. If I remove the colour image texture, the shadows and lighting are working correctly and the normal map is also working. The alpha map is also working. I am completely stumped....it all works PERFECTLY in Eevee - it's gorgeous model even if the colouring is a little rudimentary. $\endgroup$ Jan 25 at 18:54
  • $\begingroup$ please edit the question with the info, don't add it in comments, some users do not read comments. $\endgroup$
    – susu
    Jan 25 at 18:58
  • $\begingroup$ Do you have any lights in the scene? Seems like the image on the left is lit only with the environment, so there is light coming from all directions making the image have no distinct shadows. $\endgroup$
    – susu
    Jan 25 at 19:11
  • $\begingroup$ Ok - noted about updating any new information in the main text. I didn't really have much - just other stuff I tried. To answer your question, lights were the first thing I tried experimenting with. Also adding in an HDRI and environment lighting. It is definitely something related to the image texture. I'm puzzled as to why it works fine in Eevee but not Cycles. $\endgroup$ Jan 25 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.