0
$\begingroup$

I would like the cloth to fall and hit the bricks, but it just passes through. I've replaced the bricks with a rigid cube before and it does the same thing. Am I missing something? I'll include the file and a GIF.

ThanksCloth Passing Through

$\endgroup$
4
  • $\begingroup$ File is not included just a GIF that is not illustrative enough.To attach your simplified blend file to see your setup, use blend-exchange.giantcowfilms.com and paste given code into your question. In meantime just to be sure ... do you have to set "Collision" to Brick Wall? $\endgroup$
    – vklidu
    Jan 23 at 21:41
  • $\begingroup$ Hello Vkildu. I've been trying to upload the file for a while to no avail. I did set the collision to brick wall but that didn't work either. Hopefully I can get the file to go through soon. Thanks for the reply! $\endgroup$ Jan 23 at 22:08
  • $\begingroup$ Share your file any other way so I can try to attach for you here. Just delet all that doesn't generate your issue. BTW Instead of bricks you can use any other object as whole a wall and hide it from rendering. $\endgroup$
    – vklidu
    Jan 23 at 22:33
  • $\begingroup$ Here is a download link: dropbox.com/s/uijtt1smq2jh4ii/banners.blend?dl=0 Hiding a wall during the render is a good idea! didnt think of that. $\endgroup$ Jan 23 at 22:57
2
$\begingroup$

When I asked to simplify the blend, I ment to keep one example of cloth, only bricks that directly collide with cloth, there is no need to keep brick with a huge amount of vertices for this issue, so Decimate modifier could be applied (it slows down calculation any time you run simulation). You have also set Fake User for many objects. When deleted from a scene, they are still a part of file. To get rid of them you have to go into Outliner > Ophan Data > uncheck all of them and hit Purge. If objects are still there you can select them manually with Shift and with right-click choose Delet. Like that you can go from 184 MB to just 4 MB for a blend you could share with us (saved with compression enabled).


enter image description here

Collision
If you set Rigid Body just for colision with cloth (and you don't plan to destroy a wall later), it would not work. You have to enable Collision that you can find above Cloth Simulation.

Tips:

  • If you plan just collide a cloth with a wall I would suggest you to use a simple plane (subdivided a few times), that is much faster for collision calculation.
  • To deactivate Rigid Body sim for all bricks at once - go to Scene Properties > Rigid Body World > Remove ... (it will remove all rigid body in a scene).
  • Quite annoying is cached cloth sim, that is not always updated when you change parametr. To recalculate sim with actual setup, I know only one way - deactivate&activate monitor icon on Cloth button.
  • To apply modifier for all selected objects, search for Convert to Mesh. Sounds weird, right? It is a mesh already, but this operator apply all transformations at once for all selected.
$\endgroup$
2
  • $\begingroup$ I gotcha. Thanks for the info, I'm just starting out with blender. I appreciate you taking the time to check it out, it means alot. $\endgroup$ Jan 24 at 18:33
  • $\begingroup$ You'r welcome :) If answer solved your issue consider mark it as accepted, so others with similar issue can see it from main list. Thank you keep site organised. blender.stackexchange.com/tour $\endgroup$
    – vklidu
    Jan 24 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.