1
$\begingroup$

Only just starting to learn blender animation so I'm trying to follow some basic tutorials with the FBX I'm using for my game in unity.

I was looking at this: https://www.youtube.com/watch?v=_C2ClFO3FAY

But when I perform the steps to add a keyframe, neither the dope sheet, nor the timeline populate. The keyframe does get added somewhere though, since my character still moves when scrubbing between frames. Eventually I found them in the "Nonlinear animation" window. So of course I started trying to figure out what that even is which led me down a whole different rabbit hole in which most people don't actually understand what it is either. So I tried to learn more about "NLA" which is... at least related if not the nonlinear animation window itself?

https://www.youtube.com/watch?v=-SQdHehksJw&feature=share

But now I'm even more confused because the keyframes still appear on the dope sheet and everything just fine for this guy. Just not for me.

I'll be honest in that Blender is probably the most complex program I've ever tried to use for animation. Akeytsu, UMotion and Unity itself were far more straightforward. I would love to get this to be at least somewhat closer to the workflow I'm used to.

My steps: Open new blender file Import FBX Open Animation tab Select 1st frame in dopesheet/timeline/whatever Rotate bone click I => create keyframe (want to be more specific but now the I key doesn't bring up any prompt wth!) Notice no new keyframes in any window except "Nonlinear Animation"

Version: 2.81a

$\endgroup$
4
  • $\begingroup$ Hi & welcome. Made gif for blender.stackexchange.com/a/208471/15543 which I believe shows what to do. Click on action in NLA to select, TAB to edit, (turns green (in my theme)) and puts the action "in the slot". Once in the slot can add keyframes as expected. $\endgroup$
    – batFINGER
    Jan 23 at 6:26
  • $\begingroup$ Okay I clicked the action, pressed Tab and it turned green. But keyframes didn't appear in the action editor like in your gif. I see them just above the action in the NLA window but if I try to interact with them at all, it stops "editing" the action and it turns orange again. $\endgroup$
    – frostymm
    Jan 23 at 6:59
  • $\begingroup$ please share a (small and simple) file with your problem: pasteall.org/blend $\endgroup$
    – moonboots
    Jan 23 at 8:57
  • $\begingroup$ Sure thing: pasteall.org/blend/c1305422cbb64969bffc7688df1e6c48 $\endgroup$
    – frostymm
    Jan 23 at 17:56
0
$\begingroup$

No matter how many times I re-did all the steps the other day, it just would not work at all. Today everything seems fine and I've done absolutely nothing different.

Blender sure is a mystery ¯_(ツ)_/¯

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.