1
$\begingroup$

I'm following this YouTube tutorials and making fluid go through the pipe. https://www.youtube.com/watch?v=3ChtnI8GNtM

When I make pipe very thin (e,g, 0.03m in diameter), then particle size of fluid exceeds the thickness of pipe, and the particle will not go through the pipe. Is there a way to control the size of particle itself so I can make the particle go through the pipe?

enter image description here

$\endgroup$
1
$\begingroup$

First of all, your particles in your viewport display are HUGE!! IDK why you have them set so high, but suit yourself. If you don't want this and/or have accidentally changed it to look like this, then go to the particle settings tab for your fluid domain object, click on the particle settings for fluid, and go to viewport display. Scroll down to the setting for particle display "size", and set it to a reasonable size of about 0.01. Now they aren't as big.

Now, you want the particles to be smaller so they "fit" inside the tube you want to have the simulated fluid flow through.

You have to set the resolution much higher to do this. Currently, it appears as if you have the default resolution for fluid baking (32) set. I would recommend a value of at least 100 for preview baking, and around 200+ for final resolution baking.

To change this, simply go to the domain settings and change the "resolution divisions" to the value of your preference.

I hope this helps!

$\endgroup$
1
  • $\begingroup$ Thank you!!! That worked!! $\endgroup$ – pcparts Jan 21 at 6:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.