1
$\begingroup$

All of a sudden, my system stopped rendering via GPU. It renders fine via CPU, it looks like the error has something to do directly with my graphics cards too. I have tried rendering via CUDA and OPTIX, no luck. I have tried 3 different versions of Blender (2.90, 2.91, 2.92 beta). I have reset my preferences, uninstalled, re-installed graphics drivers, roll back graphics drivers and nothing. I was able to test rendering. I ran heaven benchmark on direct x11, cinebench (Only openGL), and ran Counter Strike on high settings with no problem. I lastly ran Compubench 2.0 which I believe tests via the CUDA API. Computer specs and the error from the blender console below. Thanks to whoever can help me in this confusing endeavor.

SPECS CPU: AMD RYZEN 7 1700 RAM: 16GB 3200 GPU: 2 x GTX 1060 MOBO: AsRock x370

ERROR Illegal address in cuCtxSynchronize() (device_cuda_impl.cpp:2016)

Refer to the Cycles GPU rendering documentation for possible solutions: https://docs.blender.org/manual/en/latest/render/cycles/gpu_rendering.html

Illegal address in cuGraphicsMapResources(1, &pmem.cuPBOresource, 0) (device_cuda_impl.cpp:2102)

Refer to the Cycles GPU rendering documentation for possible solutions:
https://docs.blender.org/manual/en/latest/render/cycles/gpu_rendering.html

Illegal address in cuGraphicsResourceGetMappedPointer(&buffer, &bytes, pmem.cuPBOresource) (device_cuda_impl.cpp:2103)
Illegal address in cuModuleGetFunction(&cuFilmConvert, cuModule, "kernel_cuda_convert_to_half_float") (device_cuda_impl.cpp:1971)
Illegal address in cuFuncGetAttribute( &threads_per_block, CU_FUNC_ATTRIBUTE_MAX_THREADS_PER_BLOCK, cuFilmConvert) (device_cuda_impl.cpp:1993)
Illegal address in cuFuncSetCacheConfig(cuFilmConvert, CU_FUNC_CACHE_PREFER_L1) (device_cuda_impl.cpp:2000)
Illegal address in cuLaunchKernel(cuFilmConvert, xblocks, yblocks, 1, xthreads, ythreads, 1, 0, 0, args, 0) (device_cuda_impl.cpp:2012)
Illegal address in cuGraphicsUnmapResources(1, &pmem.cuPBOresource, 0) (device_cuda_impl.cpp:2116)
Illegal address in cuCtxSynchronize() (device_cuda_impl.cpp:2016)
$\endgroup$
3
  • 2
    $\begingroup$ Related or dupe: blender.stackexchange.com/questions/102536/… $\endgroup$
    – brockmann
    Jan 18 at 10:34
  • $\begingroup$ Doesn't matter the scene. Its the same outcome if its only a single cube. I also forgot to mention that this happens via the viewport as well. If I try to render via F12, nothing happens. Error is thrown immediately and blender crashes. $\endgroup$
    – Joey
    Jan 18 at 20:16
  • $\begingroup$ I noticed that this problem occurred if the render mode is selected in the viewport. If you switch to any other one, then my error disappeared and the rendering on the video card occurred. If this is not done, then the render can only be done on the CPU $\endgroup$
    – Denny N
    Sep 22 at 9:39
1
$\begingroup$

Solved. I yet again reinstalled my nvidia drivers, except this time I made sure Windows did NOT automatically update my drivers, and manually updated with the latest. For the record, the Nvidia driver version I am now using is 432.00.

$\endgroup$
1
$\begingroup$

An Update to this problem. For me, all Nvidia drivers after 432.00 cause this problem. This maybe because I have older GPU's in my system that I HAVE pushed to the limits for some time, or something else. However, as a warning for Windows users, I am finding even when I turn off automatic driver updates windows STILL decides to update my drivers. If this happens to you, just download the 432.00 driver (or whichever is the closest one that works for you) and keep it somewhere on a hard drive. After all the clean installs have been pretty damn quick.... I should have just kept my system linux.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.