4
$\begingroup$

I have this bogie:

enter image description here

It's textured with UV Map in a dark grey as you can see in texture view. However when rendering, it's nicely rendered, but no texture is to be seen:

enter image description here

I checked this question/answer already: Render not showing UV texture

EDIT: I did all the steps mentioned in various tutorials and in the Blender wiki:

I added a material, then a texture. I created seams, unwrapped my mesh, saved the UV layout, changed its colour to dark grey and assigned the image back to the texture. In texture view you can see the result:

The frame is just plain dark grey, the wheel set has a light grey tread.

In render view it's just the default untextured grey.

Frame and wheels are different objects with different Materials, different Textures and different texture images.

Here is the blend.

$\endgroup$
  • $\begingroup$ In the lower right corner, where it says Map:, try selecting the UV map and see if that makes a difference. $\endgroup$ – user7952 Dec 12 '14 at 11:33
  • $\begingroup$ Yes I tried that - no difference. $\endgroup$ – Jan Dec 12 '14 at 11:55
  • $\begingroup$ Do you have right image with texture? Does your texture influence color? It is wise to drop your blend file somewhere (e.g.: Dropbox, Google Drive). $\endgroup$ – JiriHnidek Dec 12 '14 at 12:00
  • $\begingroup$ I tried it myself, just after I posted my comment, and I realised that it made no difference. You should probably post your .blend at pasteall.org/blend and put the link in your question. $\endgroup$ – user7952 Dec 12 '14 at 12:02
  • 1
    $\begingroup$ I looked at it and fiddled a little, and it appears that the texture is only applied to a very small part of one wheel. And honestly, this is for someone with more experience than I have. It's probably a simple thing, but I can't find it. $\endgroup$ – user7952 Dec 12 '14 at 13:14
5
$\begingroup$

Go to the setting of render layers. You have selected material that overwrites all materials. Remove this material and it will work.

Setting of render layers

$\endgroup$
  • $\begingroup$ I found this seemingly unused Material in the Outliner under Render Layer and wondered what this is for. I tried to remove it without success. So this is how to remove it. Thanks! $\endgroup$ – Jan Dec 12 '14 at 14:09
0
$\begingroup$

I had exactly the same problem while trying to render a simple banana. I used UV map for texturing and material and Texture Paint manually for adding some tones of brown. Everything looked great except when rendered. After having tried everything possible, I discovered this: While in 3d view: - On the top left of the screen there's a menu item called RENDER (next to FILE) - Select OpenGL render image. My image was rendered in no time and perfect! You might want to give it a try if you experience the same problem I had.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.