2
$\begingroup$

Every time I try to create a blanket and bed with cloth simulation, my blanket goes crazy (see picture). Can someone explain why this happened and how to fix it?

Cloth simulation

$\endgroup$
1
  • 1
    $\begingroup$ If you've used a solidify modifier, you should try a flat plane to do the simulation and then add thickness later. $\endgroup$ – Allen Simpson Jan 16 at 21:07
7
$\begingroup$

Issues with cloth simulations such as this are most commonly caused by either needing to Apply Scale, starting already intersecting with a collision mesh, Collision settings or Self Collision settings.

Things to try :

  1. Apply Scale on all of your meshes (the cloth and any colliders)
  2. Separate the meshes more at the start of the simulation and see if that helps avoid the erratic behaviour to rule out intersections
  3. Adjust collision settings one at a time to see how they affect collisions
  4. Check your normals are facing the correct direction on each of your collision meshes
  5. Try disabling Self Collision and/or adjust each setting to see what helps

After each stage you’ll need to re-bake the animation to ensure the new state is taken into account.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.