0
$\begingroup$

I am trying to get my render time much lower. It's taking about 10 minutes a frame. which is obviously way too long considering that I need to do over 800 frames maybe even over 1200 by the time the whole project is finished. I tried doing the following things:

  1. turning Render Properties > Sampling > Render from 128 to 64
  2. turning Render Properties > Light Paths > Max Bounces to 3 for every single option
  3. turning Render Properties > Clamping > Direct Light and Indirect Light to 0.00
  4. unchecking Render Properties > Caustics > Reflective and Refractive Caustics

The most confusing thing is that changing these setting has actually made rendering take LONGER??!
Right now my peak memory use is over 21 GB??! I have no idea what's going on.

P.S. I am using a de-noising node in the compositing tab. Also, I'm using Blender 2.91 with the Cycles Render Engine and Windows 10.
enter image description here

$\endgroup$
2
  • $\begingroup$ I'm going to post an answer with a few things, but does this scene happen to have a bunch of objects that were appended to the scene? $\endgroup$ – Allen Simpson Jan 14 at 23:07
  • $\begingroup$ A different version of the same question pops up regularly on this site. And most times folks casually forget to mention a description of the scene in terms of millions of vertices, size of the textures, and modifiers or simulations used... 3D can create scenes that require heavy computing power and resources that might exceed those of your particular computer. Please add information about your scene. $\endgroup$ – susu Jan 15 at 4:01
1
$\begingroup$

Every step you listed except for clamping probably helped out.

Turning clamping to 0 actually unclamps them completely. You need some value in there, I think indirect is clamped at 10 by default and unclamping it increases render times pretty significantly. It probably wiped out all the gains made by the other methods.

As for the memory usage, check your materials for duplicate image textures. If you're using high-resolution textures and you think you could get away with a lower resolution, that will take less memory.

You can go this menu -

enter image description here

and lower your viewport settings and maybe cut down on the geometry that blender has to keep track of outside of the rendering process.

Consider adaptive subdivision if you have any highly subdivided meshes.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.