3
$\begingroup$

I made a liquid animation. It looks good, but it looks like tiny balls instead of liquid.Blender output of what it looks like

How can I fix this?

$\endgroup$
1
  • 1
    $\begingroup$ Hello and welcome, I would recommend to add more detail to the question, as for example which version of Blender you used, and maybe some details about the settings in your scene. You can use the Edit function to add these details and make it easier to solve your problem. The answer I wrote explains the possible situations, of which depending on a more detailed question maybe one might have been enough. The risk of the question being closed and you not getting help increases with lesser information by default. $\endgroup$
    – Xylvier
    Jan 14 at 16:08
5
$\begingroup$

While I can't say which version you use, I can be sure that you use a version of Blender that uses Mantaflow.

There are still some unknowns, so I try shine some light on the possibilities.

  1. You use the Replay default setting of the "Domain-Cache"->Type:
    Domain type set to replay
    With this you will not be able to scrub through the timeline as each frame needs to be simulated, BUT it's still possible to activate the Mesh option:
    Mesh simulation active
    Beware that for this to show properly the domain-object must not be set to be displayed as "Bounds", else you would not see any form of geometry. With this setting you can run the simulation and should (slower then without the Mesh active) see the fluid shown as geometry. This is nice to get an idea and fine tune the simulation.
  2. Should you have set the "Domain-Cache"->Type to any other of the available options like Modular, then you need to bake the simulation and by default the Mesh won't be baked along with it. That is to say, once the liquid is baked to the point you showed, all you need to do is activate the Mesh subpanel and in this panel will be a Bake Mesh button:
    Bake option in the Mesh subpanel
    This button won't be there if in "Domain-Cache"-Type Replay mode. And the button will be greyed out if the simulation is not baked beforehand. Thus first bake the liquid, then you can bake the mesh. And different then in the 1st mentioned solution, you can not see the mesh simulated along with the blue particles in one go. There is a final "Domain-Cache"-Type option All, which essentially on pressing the Bake All button:
    Bake All option shown only if Domain-Cache-Type is set to "All"
    This will simulate/bake all activated options in one fell swoop. While it may safe the separate baking and clicking, it may be most helpful for all set up(after trial and error and finetuning) simulation settings as a QoL option.

    Happy Blending.

The pictures are taken from the 2.93 alpha version, BUT the differences to the latest stable version are not big enough and should not cause any confusion.

$\endgroup$
4
$\begingroup$

The mesh of a liquid-simulation needs to be activated seperately, and is not turned on by default. (probably for performance reasons)

Make sure that you have the "Mesh"-option in the physics tab of your domain object anabled.

mesh option for fluid sim

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.