rendered on GPU

To save time, I set up an EC2 machine running Ubuntu with a Tesla K80 GPUs to render a scene saved in a blend file. I rendered in the background using this command:

blender -b room.blend -P set_gpu_for_rendering.py --render-output //test_ --render-format PNG --use-extension 1 --render-frame 1

While the rendering took just about 3 mins to complete, the wall looked really rough and significantly different from the original look of the texture see here. Also, the floor texture looks pretty good in comparison. So the problem doesn't seem to be an universal issue of using JPEG textures, which was my first thought.

I wonder if anyone has faced this or a similar issue of significantly different rendering when done on GPU vs on CPU.

While I'm also wondering if I'm setting all the parameters of cycles to render properly, what confuses me is that when I render the same blend file with same settings on my MacOS machine without GPU, it comes really good without any issues. See the attached image below. But it took 45 mins to render this scene.

Appreciate your help!

rendered on CPU


1 Answer 1


While I solved the problem by removing the displacement map from the PBR material, I'm not 100% certain why the issue wasn't affecting the rendering output when done using a CPU alone.

My understanding so far for why this worked: Each wall is represented using a few triangles whereas the displacement map needs a finely divided mesh to cause micro displacements to make the surface looks like the material. With only a few large triangles to adjust, the algorithm is unable to do it correctly and the error manifests itself in the form fo this jagged surface.

Please feel free to comment if you know what might be happening here.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .