2
$\begingroup$

The Boolean tool is exactly what I'm looking for, according to the countless videos and screenshot tutorials showing it working perfectly. However, I can't get it to work. Here are my steps:

  1. Create a circle w/ face
  2. Extrude the lines to give the circle some volume
  3. Move the circle to intersect the mesh, where I want the hole to be
  4. Add the boolean modifier to the mesh
  5. Select the circle as the object, in the modifier
  6. The result is in the screenshot.

No hole, and an ugly deformation in the mesh. Can anyone help?

enter image description here

$\endgroup$
1

1 Answer 1

3
$\begingroup$

There are two things going on here. Your extruded circle is still visible, so it is hiding the hole. If you go into the outliner and press the eye to hide it, it will disappear leaving your hole. (You didn't need to extrude a circle, you could have used a cylinder.

Here's an example: cylinder cutting hole in mesh

Now I hide the cylinder in the outlinerhiding cylinder in the outliner

and the hole is obviousactual hole

Be warnedThe cylinder will still show up in a render. You need to also click the 'camera' icon to keep it from being rendered.

The second thing is a lot harder to deal with, but basically by creating the hole, you've given your object "bad" topology. There are entire courses on how to fix topology so I can't solve your problem in a single example.

One quick thing you can try is selecting your object, setting it to smooth shading, and then in the Normals property select autosmooth.

$\endgroup$
1
  • $\begingroup$ Using "Shade Auto Smooth" instead of "Shade Smooth" as you suggested did the trick for me. $\endgroup$ Jan 9, 2023 at 23:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .