My ambient occlusion bake in cycles for a sword has only black and white color and none of the recognizable grey gradient shading that goes with ambient occlusion. I am using the 'selected to active' option so I've got my low res and high res with detail models all set up. I followed this 'answer', How do I bake a texture using Cycles bake, in achieving my setup.

Here is an image of the bake.

ambient occlusion bake

Here is an image of the high res model.

high res model

Here is an image of what I'm thinking the AO should look like. It is from a tutorial I am doing on this sword.

enter image description here

Now the sword handle bands from the high res model extrude further out than then the low res model's sword handle geometry. To compensate for this, I enabled the 'cage' option and used an extrusion setting that matched the length of the farthest distance that the high res handle bands extruded out from the low res handle, which is cylindrical only. The rest of the sword geometry comparison between lower and higher res models is almost identical except for some high res scratches and detail sculpting.

I'm basically looking for something I may be missing in the entire setup of models and settings for ambient occlusion baking, in order to get that nice ambient occlusion grey gradient shading on my texture.

  • $\begingroup$ I'm not 100% sure, but have you tried checking normalized? $\endgroup$ – Knuckles209cp Dec 11 '14 at 7:07
  • $\begingroup$ That setting is for blender internal. The question is concerned with cycles. $\endgroup$ – RedKrovvy Dec 11 '14 at 18:20
  • $\begingroup$ Are you sure there even is any place on your model where AO would produce a gradient? Have you tried comparing it to a test render with only a AO node, connected to the output, for the material? $\endgroup$ – someonewithpc Dec 11 '14 at 20:00
  • $\begingroup$ I tested out your suggestion. The model does produce the AO gradient, especially on the handle bands but also in dents in the sword to a lesser degree. $\endgroup$ – RedKrovvy Dec 12 '14 at 2:37
  • $\begingroup$ @someonewithpc I can see some place does has AO, see the small islands on the middle right side, or some blades. That looks normal. $\endgroup$ – Leon Cheung Dec 13 '14 at 2:40

Cycles Baking behaves a bit different from BI Baking due to the design. However, you can simulate what you expected by creating an auxiliary object, and tweak the Distance value located in World tab to get rid of the "normalized" look.

  1. Create a big enough object, center it to the target objects;
  2. Tweak the Distance value based on the dimension of the new object. (As shown below, I created a 20 x 20 x 20 cube object, so that the distance between the sword and cube is around 10.)

enter image description here

| improve this answer | |
  • $\begingroup$ The model itself produces ambient occlusion that does not look like the baked texture in the question, though. I was following a tutorial for this sword where the tutor used Topogun for AO baking, whereas I am going with Blender, and the tutor's AO bake had the AO-associated gray gradient shading for the AO that occurs in the ridges of the sword handle bands. $\endgroup$ – RedKrovvy Dec 12 '14 at 18:55
  • $\begingroup$ Then two suggestions: 1. upload your .blend file, you can upload it here; 2. upload a picture here to show what it should look like (in Topogun for example). I suppose you need to tweak the cage setting. $\endgroup$ – Leon Cheung Dec 13 '14 at 4:04
  • $\begingroup$ Ok, I've uploaded the blend here, pasteall.org/blend/33326. I edited the question to include that Topogun AO bake image. $\endgroup$ – RedKrovvy Dec 14 '14 at 4:00
  • $\begingroup$ OK. I hope the updated answer helps. $\endgroup$ – Leon Cheung Dec 14 '14 at 5:38
  • $\begingroup$ I see the AO working, as I wanted it to, but I'm not understanding how this way isn't the correct one. Can you explain this a bit more? Also, I don't get how making the container box did the trick for getting the AO the way I was seeking. Can you explain a bit more here too? $\endgroup$ – RedKrovvy Dec 15 '14 at 2:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.