1
$\begingroup$

I’ve been having trouble enabling the pen pressure when using Blender grease pencil using my iPad connected to my PC using the EasyCanvas Pro app.

The brush strokes I make stay the same size and opacity no matter how much pressure I use and even when I change the size and strength of the pen. I set my preferences to use the Windows Ink for the tablet API and have the pen pressure sensitivity icons for the size and strength enabled. I tried the other options for the tablet API and restarted the program each time but I still have the same issue.

Any help is much appreciated!

Update Here’s a snapshot of the issue I’m having: enter image description here

Update I found that if I switch from wireframe to viewport shading, my pen strokes don’t really show. But when I draw with my finger, the stroke matches the opacity and size I set enter image description here

And when I switch to wireframe it reverts back: enter image description here

$\endgroup$
0
$\begingroup$

chiyopet,

If you are using Grease pencil, there could be a couple things that are causing the issue.

Lets get the basics out of the way:

If you new to Blender...Welcome! if you not and having trouble, a really simple things would download a fresh copy of Blender from https://www.blender.org

on the slashscreen click "2D Animation"

enter image description here

start drawing with you iPad.....(I have no idea what application your using to draw with ....so that could be getting in the way...but let see if we can help you. If this works.....wonderful! if not, keep reading.

Then follow these directions:

  1. Start Blender
  2. Click "File" in top left corner and select "New" > "2D Animation" from the dropdown list

This will open the 2D Animation workspace and with a grease pencil object selected and in the "Draw" mode with the Draw Tool Selected. It will also have a material for you selected to draw with.

All this means that Blender is ready for you to Draw in 3D.

Try to Draw....if you still do not see anything.

A) Check you are in Draw Mode: Look in top right corner of 3D Viewport: enter image description here

B) Check that you have the large enough brush size and strength of brush and most importantly that you have "Use Pressure" icon checked: Here is a nice graphic with a copy of setting for you to use:

C) Check 3D Viewport is in the correct Viewport Shader. If you look on the top right side you will most likely want to be in "Material Preview" or "Rendered"

enter image description here

Here is the blender Documentation on the what the different Viewport Shaders https://docs.blender.org/manual/en/latest/editors/3dview/display/shading.html

This video does a good job of at least giving a quick overview of viewport shading and what is does in a very quick way. https://www.youtube.com/watch?app=desktop&v=knO-oz6_ffI

$\endgroup$
8
  • $\begingroup$ Thanks for your response and helpful graphics! I included a snapshot of what I have right now. I followed the steps but I’m still experiencing the issue. You’ll see that brush size and strength are maxed out but my strokes’ size and opacity is still the same $\endgroup$
    – chiyopet
    Jan 13 '21 at 3:18
  • $\begingroup$ I have updated by answer after seeing an image of your blender screen. Please notice your The top right corner of your 3D Viewport is set to wireframe not " Material Preview" or "Rendered". I also added a link to the documention so you and anyone can learn some more amazing things blender can do!!! Happy Blendering!! $\endgroup$
    – smartdog
    Jan 13 '21 at 3:33
  • $\begingroup$ I tried setting it to material preview and rendered but the brush size and opacity is still the same. I included a new picture on an odd thing I found, but it does show that the set brush size and strength work but only when I draw with my finger. Thank you for including a link to the doc, I’ll be sure to take a look! $\endgroup$
    – chiyopet
    Jan 13 '21 at 4:09
  • $\begingroup$ Ok, you could use fingers on your iPad, then we know Blender working. For the moment, just for testing, do not use EasyCanvas Pro app. Just use "Sidecar" connecting a wire between your computer and iPad or wireless if there are on the same network". This test will find out if it in EasyCanvas Pro app is issue. 1) One the Mac, top Left corner click on (apple icon) and chose "System Preferences..." Then click on "Sidecar" and then click button under "Connect to" to select device. Just using "Sidecar" and Mac ....you should be able see strokes.....also make sure pen charged :-) $\endgroup$
    – smartdog
    Jan 13 '21 at 4:33
  • $\begingroup$ Oh would that work with Windows PC? I don’t have a Mac. $\endgroup$
    – chiyopet
    Jan 13 '21 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.