2
$\begingroup$

When I rendered animation (450 frames), I would like to composite it and add mist.

I closed Blender and than reopened it again. But when I go to the compositing and add image node with image in it, I didn't see mist button.

What can I do? I rendered animation for 4 days, so re-rendering isn't my option.

enter image description here

$\endgroup$
11
  • 1
    $\begingroup$ If you want to save channels, you have to use the .exr format, not png... I'm sorry but you have to re-render it if you want to have the mist pass. Although you can render only the mist pass to speed things up $\endgroup$ – Gorgious Jan 10 at 16:35
  • 2
    $\begingroup$ From your image you don’t have Mist but you do have Depth. Assuming that is the actual depth from the render you can use the Depth in a similar way with a bit of Maths to convert into a suitable mix factor for your mist. $\endgroup$ – Rich Sedman Jan 10 at 17:07
  • 1
    $\begingroup$ This answer includes a method of using Depth as a mist pass : blender.stackexchange.com/a/109192/29586 $\endgroup$ – Rich Sedman Jan 10 at 18:05
  • 1
    $\begingroup$ How did you render the images? did you save them as openEXR multilayer? If you didn't save the mist pass you will need to render again. $\endgroup$ – susu Jan 10 at 19:28
  • 1
    $\begingroup$ @RichSedman PNG encode only RGB and unassociated alpha (if plugged in). No more. It is not a great format. OpenEXR was designed to hold linear data, so the depth pass can be stored unbound and linear. Why is there a socket for anything else is probably an error in the design of the image node. $\endgroup$ – susu Jan 12 at 2:45
4
$\begingroup$

Short answer. Re-rendering is your only option.

PNG will not save the mist pass, or any other passes. It will only save color and alpha by default.

If you need to save multiple layers use OpenEXR multilayer.

enter image description here

When you import the rendered image back it will have the corresponding sockets for the layers you saved.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.