0
$\begingroup$

I'm clearly missing something basic, and no doubt terribly simple. I've seen videos and tutorials on constructing reflective objects, and kind of even understand them (and I'm at least sure I'm exactly duplicating their material settings).

So, I made a large plane mesh, and gave it reflective material settings. Then I built three objects that I placed just over it (red blue and green). The objects are visible, they cast shadows, etc. But the plane does not reflect the objects.

What am I doing wrong? (Also, apologies if there are random strange characters; they echo right but when I go to the next line sometimes a few characters in the previous line change to random things! Gotta reboot I guess, even on Linux.)

This screen capture shows the material the base plane is made of, and the three objects, and the lack of reflections. That orange line is the edge of the base plane, selected, so the material shown is really the material of the base plane.

enter image description here

I was hoping to upload the whole project (it being trivial and hence small), but that doesn't seem to be an option. Blender version is 2.82.7, running on Ubuntu 20.04.1 LTS.

$\endgroup$
4
  • $\begingroup$ Hello :). Reflections in Eevee are disabled by default. You need to enable Screen space reflections in the RenderTab. $\endgroup$ – Jachym Michal Jan 8 at 23:24
  • $\begingroup$ All the online help I found showed me how to use this constructed material, none of it showed how to make gloss with the "principled BSDF". I tried that first without help and failed utterly (but the failure may actually be the same failure I have here -- presumably what people said, I'll investigate that next). It's good that Blender is advancing fast -- but not so good that searching by date and with numbers doesn't work very well :-) $\endgroup$ – dd-b Jan 9 at 1:16
  • $\begingroup$ Thanks to all! Yes, the problem was (as I thought) something utterly basic, namely that reflections are off by default. Anybody taking a vote anywhere for changing that? I suspect it may be a performance issue -- but it's not too relevant for trivial beginner projects, whereas a hugely important aspect of realism being off by default IS. Wasted days on this. Advanced users with complicated projects can learn to ramp down realism for interactive performance when they need it (when they run out of money for hardware :-) ). $\endgroup$ – dd-b Jan 9 at 1:30
  • $\begingroup$ in Eevee, for proper reflections you also need to use light probes as I've explained here: blender.stackexchange.com/questions/190642/… $\endgroup$ – moonboots Jan 9 at 7:01
0
$\begingroup$

Check the Ray Visibility settings for each of your block objects. If glossy is unchecked, you won't see the object in reflections.

enter image description here

enter image description here

$\endgroup$
4
  • $\begingroup$ Hello :). I believe the OP is using Eevee so he wouldn't have these options. $\endgroup$ – Jachym Michal Jan 8 at 23:28
  • $\begingroup$ doh.wav Hello Jachym, looking closely at the shadows I think you're right. So then is this an eevee default that should be changed? $\endgroup$ – Allen Simpson Jan 8 at 23:31
  • 1
    $\begingroup$ You can tell the difference by the Pause Viewport button missing :). Still, nice answer. $\endgroup$ – Jachym Michal Jan 8 at 23:32
  • $\begingroup$ I guess I can't really upvote this since it doesn't solve my problem, but it's still useful to me to know this; who knows I may even remember it in the future sometime if I'm using Cycles. Thank you! $\endgroup$ – dd-b Jan 9 at 1:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.