3
$\begingroup$

I'm using Blender 2.91.

I'm new to Blender. I've been putting significant hours into learning it the last few days. As a learning project, since I have been a carpenter in the past, I'm building a small storage outbuilding from scratch. I've built every board and put them together to create the frame. (Here's a snip of the almost-finished framed building)

enter image description here

Everything was fine until I got up to building the roof trusses. Then, I started to figure out that Blender did not like building shapes with specified sizes into complex, specified angles.

My biggest issue is getting irregular shapes to snap to specific vertices when I wish. I thought I would narrow this down to a simple situation and see if I had some setting wrong in my more complex building blend. I started Blender from scratch, opening it into the default blend with the single cube. Next, I duplicated the cube and and "smooshed" the top of it down, and experimented with snapping the smooshed cube onto the default cube in different places.

What I found is that even though Blender graphically represents the angled faces, and the vertices at the junction of those faces, it really still treats the "smooshed" mesh as if everything were still in right angles.

I'll try to illustrate. In the image, I have attempted to snap vertex 1 to vertex 3. It DID snap, but it has treated it as if vertex 1 is still directly above (on the Z axis of) vertex 2 (yes, I am using the vertex snap setting). (see image below).

enter image description here

I added a plane to illustrate the aligned top edges of the purple and green meshes.

As stated earlier, this is an extremely simple file started from all the default settings (the only thing I changed was the snapping from Increment to Vertex. What am I missing? How can I get vertex 1 to snap to vertex 3 without changing the shape of the green mesh?

I don't mind to upload the file the image is taken from, but I don't see any option for that.

Thanks for any advice.

$\endgroup$
4
  • 1
    $\begingroup$ Hello :). A very similar Q&A here: How to align mesh parts? $\endgroup$ Jan 8 '21 at 9:48
  • $\begingroup$ .. You could also consider using the 3D Cursor to mark your 'From' point, in some workflows. BTW, thinking like a carpenter is a great way to do precision modeling, in what is not, after all, a purpose-built CAD application, IMO) $\endgroup$ Jan 8 '21 at 10:00
  • 1
    $\begingroup$ @RobinBetts Thanks for your comment. I thought I had tried setting the pivot point using the 3D cursor, but it did work for me just now. $\endgroup$
    – Zoomstrat
    Jan 9 '21 at 16:29
  • $\begingroup$ @JachymMichal Thanks for your comment. I don't know what will end up being more useful to me in most situations (your link info vs. setting the pivot point), but I can see that the info at your link could certainly help me in situations where I'm wanting to align vertices in a mesh in a way that changed the shape of the mesh I'm working on. $\endgroup$
    – Zoomstrat
    Jan 9 '21 at 16:32
3
$\begingroup$

I'm posting this just so I can post some pictures easily - if it doesn't help, let me know and I'll delete it.

I think what you're looking for is to choose which vertex is the "snap point" on the object you're moving to snap.

To do this make sure to select your whole object (in edit mode), making sure the vertex you want to snap is selected last (the active vertex). Then, from the snap menu, choose "Active":

Snap1

From here, move the object (G) and place your mouse cursor over the vertex you want to snap to. The object should snap aligning the vertex you left active, with the one you selected with your mouse:

Snap2

$\endgroup$
2
  • $\begingroup$ Nice :). Or you can use Pivot point > Active Element instead, which also moves the gizmo to the active vertex. $\endgroup$ Jan 8 '21 at 9:50
  • $\begingroup$ @ChristopherBennett I thought I had tried moving the pivot point before, and had trouble getting it to do what I wanted, but it is working now. Thanks for your help. $\endgroup$
    – Zoomstrat
    Jan 9 '21 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.