2
$\begingroup$

SOLVED : so this morning, I started the computer and it worked. That's it!

I cannot draw with the grease pencil tool, it acts like an eraser, although the pencil mode is selected. I found this topic, Blender 2.8 Grease Pencil displays [Report ERROR: Nothing to erase or all layers locked] when trying to draw, but it did not solve my issue. I tried to change "windows ink" or "automatic" in Edit > Prefs > Input > Tablet API . When I try to draw with my mouse, it only creates like an "arch", as you can see on the picture. it does not follow the movement of my mouse, it only draws a portion of an arch. enter image description here

enter image description here

I'm using blender 2.9. Thanks

$\endgroup$
4
  • $\begingroup$ Hello, could you add a screenshot of your grease pencil layers, and of the material you are using ? $\endgroup$ – Gorgious Jan 7 at 14:06
  • 1
    $\begingroup$ Also, you can deselect "Guides" in the top row if you want to stop drawing in arcs : i.stack.imgur.com/eTSeg.png $\endgroup$ – Gorgious Jan 7 at 14:07
  • $\begingroup$ @Gorgious thanks! it solved the issue for the mouse, but not with the stylus, it just erases instead of drawing. I added a picture $\endgroup$ – Maverick3808 Jan 7 at 14:31
  • 1
    $\begingroup$ When I start Blender with my mouse, it doesn't recognize the pressure on my stylus afterwards. I have to launch it with the stylus for it to recognize it. Don't know if it is a problem with the OS or with the drivers, or Blender, but it might help if you have trouble again. $\endgroup$ – Gorgious Jan 8 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.