2
$\begingroup$

I am using Blender 2.91 and a Huion stylus. I set up a simple mesh, with a texture material, and switched to texture paint mode, using the default brush. Everything is working great when I use the mouse, but when I use the stylus it's behaving like an eraser and it's clearing whatever I touch to alpha 0. See video below.

Mouse is painting, stylus is erasing

Larger image. Left screenshot is what I get after left-clicking with the mouse and dragging; right screenshot is stylus-down and dragging.

Mouse is painting, stylus is erasing

What's going on?

Some ideas

Could it be a virtual/button/mapping issue of some sort? Under which condition the same thing would happen when using the mouse? Maybe if a modifier key is pressed?

$\endgroup$
2
  • $\begingroup$ It's pretty hard to make out what's going on from such a small gif. Could you edit in a couple screenshots in instead? Win + Shft + S is a good way to do screenshots on Windows. $\endgroup$ – HISEROD Jan 6 at 16:57
  • $\begingroup$ Thank you, I am going to use Win + Shft + S a lot from now on! $\endgroup$ – damix911 Jan 6 at 18:15
0
$\begingroup$

Even though the poster was having a different problem, one of the answers to another question Painting problem when using pen in Blender seems to do the trick for me. If I change the Preferences > Input > Tablet > Tablet API to Windows Ink then the stylus paints with the selected color.

I have no clue why this is happening though; I will accept any answer that sheds some more light on this issue.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.