3
$\begingroup$

When compositing my render with an alpha over node to be able to edit my background and my foreground separately, if I use a defocus node to give my image some DOF, I always run into those weird artifacts that happen at the transition between the "in focus" zone and the "out of focus" one.

Anyone knows how to get rid of that? I'll attach my color ramped mist pass and the result.


The mist pass:

enter image description here

The result with artifacts:

enter image description here

$\endgroup$
7
$\begingroup$

For best quality with the Defocus node, uncheck the "Preview" radio button.
This will calculate slower, but give much better results.

Also, if you use the Depth buffer, the Defocus node can automatically use the Focus Distance of the active camera in the selected scene to calculate the blur.

See Blender's manual.

$\endgroup$
2
  • $\begingroup$ Thanks for your suggestion ! I disabled the preview mode and the quality improved indeed, I have no idea why I didn't try that before... However after reading the doc on defocus I ran some tests and noticed that overall the performance of the node were quite limited in some scenarios like overlapping objects and high contrast areas that were of course rendering much better with default camera DOF. I guess I'll have to balance my scenes between separate layers , natural DOF and defocus node to achieve the best results. Thank you for your time ! $\endgroup$ – Poppip Jan 7 at 17:40
  • $\begingroup$ Even in their example in the doc you can see that the foreground balls edges are poorly blurred ! $\endgroup$ – Poppip Jan 7 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.