0
$\begingroup$

I created a water particles but they seems to hang over the surface, why is this happening?

enter image description here


Still the water hangs over the ground even with Collision Surface Thickness zero:

enter image description here

$\endgroup$
2
  • $\begingroup$ could you upload a link to your file so I can take a closer look? you can use this link: blend-exchange.giantcowfilms.com $\endgroup$ – ETHAN DAY Jan 4 at 15:39
  • $\begingroup$ check the "Thickness" of the Effector -> Collision objects. Set them to 0 or 0.001, as that is the distance BEYOND the mesh that effects the liquid $\endgroup$ – james_t Jan 4 at 18:47
1
$\begingroup$

Here is a fluid simulation with a liquid Effector Collision Thickness of 3 vs a Thickness of 0 enter image description here enter image description here

and here is a domain where collision distance is too large and particle radius is rather large (2.0): enter image description here

In other words, try dropping your collision thickness to '0' and particle radius to < 1.0.

$\endgroup$
1
  • $\begingroup$ Karol react to your suggestion by "I tried everything you said, but it didn't work. How can I get over with this? I drop the thickness to 0, then to 0.000001 and nothing...". His post was hidden because was written as answer and not as a comment. $\endgroup$ – vklidu Jan 17 at 10:49
0
$\begingroup$

Your domain is too big, scale it down as much as possible to just cover expected simulation range in a scene. Something like this ...

enter image description here

You use a lot of colliders with very chaotic topology. I would suggest to use one simple that would be faster in simulation and it prevent from leaking water. Bake simulation and for rendering disable this simple collider in Outliner.

In this example I used a subdivided Plane with Shrink Wrap modifier > Projection > Z to quickly recreate your colliders.

enter image description here

Increase value for "Resolution Divisions" that is too low. 64 is not enough to generate a grid dense enough to bring water closer to collision objects. One division is represented as a cube in domain corner. Amount of divisions is always a longest side of domain divided by this number.

This is your current Domain with Res.Div. 64 enter image description here

My Domain scaled down with Res.Div. 64 enter image description here

My Domain scaled down with Res.Div. 128 enter image description here

My Domain scaled down with Res.Div. 256 enter image description here

So as you can see each time the Resolution Division is increased, simulation is closer to collider thanks to detailed grid (division) of domain.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.