4
$\begingroup$

I'm trying to make some LED lamp but the EMISSIVE feature doesn't react as I expect. I read on the Blender manual that the emission power is defined in Watts per Square Meter. It doesn't really seem to work the right way. From 0 to 1 it works well, but then, raising it to 10, it's not decuplicating the light, and even shooting it to 100000 won't really change much.

You can see in the images how the change from 1000 to 10 millions doesn't change anything in the final image.

For a test, I added an area light on top of the emissive model, and a 1 W light assigned to it makes faaaar more light than the emissive material. You can see the difference in the final image.

What may be happening here?

Now, I may trick and just use the area lamp, but I want to know what is happening so to know how to work in the future.

CYCLES - POWER: 0.5

CYCLES - POWER: 1000

CYCLES - POWER: 10000000

CYCLES - AREA LAMP 1 W

EEVEE - POWER: 0.0

EEVEE - POWER: 1.0

EEVEE - POWER: 1000.0

Real world sizes. Emissive surfaces are exposed, nothing in between.

Actually, Eevee is not really lighting anything with the model, it just adds glow, a lot of it XD

Tried in a brand new scene, same problem: emissive power doesn't do anything past a certain threshold. It looks like the power is logarithmic. You can download it here:

Also added the original file:

$\endgroup$
8
  • 3
    $\begingroup$ if you are in Eevee, the emission strength won't change anything unless you use a Light Probe > Irradiance Volume, so you'll need to add a light of use a light probe $\endgroup$ – moonboots Jan 3 at 22:11
  • $\begingroup$ I never experienced such issue. Have you tried in a simple, brand new file? $\endgroup$ – Carlo Jan 3 at 22:12
  • $\begingroup$ In the 4th img Use Nodes hasn't been clicked? $\endgroup$ – HISEROD Jan 3 at 22:23
  • $\begingroup$ @HISEROD in the 4th image the selected object is the AREA LAMP, I don't need nodes to use that. $\endgroup$ – PolyMad Jan 3 at 22:25
  • $\begingroup$ Could you add a blend file? blend-exchange.giantcowfilms.com $\endgroup$ – HISEROD Jan 3 at 22:26
8
$\begingroup$

The problem is the light clamping setting.
enter image description here
Set "Direct Light" to 0 to fix the power issue.

Setting the clamping to 1 means that any value brighter than 1 is clipped (or ignored), therefore it doesn't matter if the lights are set to an intensity of 1 or 1 million. Setting it to 0 means that the lights are un-clamped, therefore using their real values.

Read: What is Clamp Direct/Indirect?

Additionally, I would recommend setting the color management to filmic for more realistic tone mapping. Standard transform is usually used for video editing.

$\endgroup$
2
  • 4
    $\begingroup$ When using filmic you are using a much larger dynamic range, where the values can be much brighter than 1. Read: blender.stackexchange.com/questions/46825/… $\endgroup$ – susu Jan 4 at 0:10
  • 1
    $\begingroup$ Oh ghosh... I thought that parameter worked in a completely different way. Thank you very much for your help!!!!! $\endgroup$ – PolyMad Jan 4 at 0:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.