4
$\begingroup$

I have transferred a texture across objects using the "Data Transfer" modifier. But when the texture is on the new object, the textures are split apart strangely (along the seams). How can I fix this? Because I'm planning to sell this object, I've uploaded a photoscan file with the same problem (it always seems to happen.)

enter image description here

$\endgroup$
5
  • 1
    $\begingroup$ Your file doesn't have the textures packed. $\endgroup$ – HISEROD Jan 5 at 17:54
  • $\begingroup$ Thanks for notifying me, I just fixed it! $\endgroup$ – Pro Effects MAX Jan 5 at 19:15
  • $\begingroup$ It looks like the data transfer isn't generating UV seams fsr. Maybe you could bake with clean uv's instead of using data transfer. $\endgroup$ – HISEROD Jan 5 at 19:36
  • $\begingroup$ Yeah, baking worked for me. $\endgroup$ – HISEROD Jan 5 at 19:49
  • $\begingroup$ Can you explain the process? I'm not quite getting what your saying. $\endgroup$ – Pro Effects MAX Jan 5 at 21:04
9
+100
$\begingroup$
  • Delete Data Transfer modifier.
  • Create a UV map.
  • Create a new image in the image editor.
    new img
  • In the low poly object's material nodes, click the blue thing to make it a separate material from the original object's.blue thing
  • Unlink the image from the Principled BSDF and select the new image.
    select img
  • In the original material, plug the texture into the Material Output.
    orig mat
  • Select the original object then the low poly object so that it is active.
  • Make sure the disconnected image node is selected in the node editor.
    disconnected image node
  • In Properties Editor → Render Properties, set up the Bake section something like this.
    (This section is only available for CPU rendering.)
    bake
    The Extrusion setting is the one to fiddle with.
  • After setting the render samples to a low number (1 worked for me), click Bake.

This should leave you with a nice new image texture that will work with the UV map that you created.

rock

$\endgroup$
7
  • $\begingroup$ When I do everything you said, and try to bake them, I get an error message that reads "No active UV layer found in the object" $\endgroup$ – Pro Effects MAX Jan 8 at 20:39
  • $\begingroup$ Did you make a uv map? $\endgroup$ – HISEROD Jan 8 at 20:42
  • $\begingroup$ Do you mean the thing you named "whoopee"? If that is the case, then yes I did. $\endgroup$ – Pro Effects MAX Jan 8 at 21:01
  • $\begingroup$ No, a UV map not an image texture. youtube.com/watch?v=Y7M-B6xnaEM $\endgroup$ – HISEROD Jan 8 at 21:03
  • 2
    $\begingroup$ @HISEROD you don't even need the Emission node, just plug image directly into Surface socket of Material Output node $\endgroup$ – vklidu Jan 8 at 22:54
1
$\begingroup$

The problem with the data transfer modifier not transferring seams is that the original model didn't have any UV seams marked.

To fix this, select the original model, change to the UV editing layout, and select Seams From Islands.
Seams From Islands

Now, in the data transfer modifier of the low poly model, Switch to Nearest Face Interpolated for best results in this scenario.
Nearest Face Interpolated

This doesn't yield perfect results, but it does eliminate most of the distortion around seams.
Stretching and Visible Seams

Also, I wouldn't recommend this solution in a case where the original UV map takes up such a tiny amount of the available texture space.
Ouch

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.