0
$\begingroup$

I'm trying to download and install the MTree Addon (latest release) from Github on a MacBook Pro Catalina 10.15.7 Blender v2.83.4.

It is the first time I'm trying to download a 3rd party addon, so it's highly likely that I'm making a mistake.

What I've done so far:

  1. Downloaded the .zip file from Github and unzipped it

  2. Copied the file containing the .py scripts and pasted it in the Blender "addons"-folder

  3. Opened Blender then Edit>Preferences>Add-ons, where the checkbox for the mtree-addon doesn't seem to show up.

Then I tried:

  1. Copy same folder containing .py files

  2. Pasted it in the "addons_contrib"-folder

And this message shows up in the "Add-ons" section of "Preferences" in Blender:

Multiple add-ons with the same name found!

This conflict confuses me, since it means that the contents of the folders are recognized but, as I said, the checkbox for the add-on doesn't appear in the Preferences.

Any help or idea as to what could be the problem?

$\endgroup$
4
  • $\begingroup$ Does this answer your question? Multiple addons using the same name (OS X) $\endgroup$ – Timaroberts Dec 30 '20 at 19:16
  • $\begingroup$ I looked through your link, but the problem that I'm having is not that I can't identify two add-ons with the same name, but rather that the addon in question doesn't appear as a checkbox under Preferences>Add-ons. I can easily delete the folder from either "addons" or "addons_contrib" and the conflict will disappear, but my problem remains. I only posted the picture with the conflict to show that Blender seems to recognize the contents of the folders, but fail to display the UI-components. Thanks for taking your time to look up a possible solution, appreciate it! $\endgroup$ – Anton Dahl Dec 30 '20 at 19:42
  • $\begingroup$ You should be able to go to the addons window and hit Install in the top right and pick the zip file from the file browser. Try installing it that way. $\endgroup$ – Allen Simpson Dec 30 '20 at 23:18
  • $\begingroup$ I tried your method Allen, and it seemed to work! I encountered an error message besides the add-on checkbox which told me to upgrade to 2.8x (I wasn't sure if it was referring to blender or the add-on), but since I was running on Blender 2.8 already I went to Github and switched branch to 2.8 instead of the latest release and this solved my problem. Thank you! $\endgroup$ – Anton Dahl Dec 31 '20 at 17:10
0
$\begingroup$

You have to download the 2.8 version of mtree i have version 2.83.10 and had the same problem when i downloaded the master but you need the 2.8 version. to do that goto: github

after downloadin the zip just goto preferences addon - install addon - navigate to zip and click install addon, wait a few seconds and then select mtree from the checkbox and mtree awayyyyy...

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.