0
$\begingroup$

I would like to take an irregular shape and extrude it up. I would then like to apply a different finish to the top/bottom faces to the side faces. For example glossy on top and matt on the sides. When I apply the subdivision surface on my object (after Edge Split) I get some artifacts. Either the top surface edge becomes jagged, or I get a surface artifact. Does anyone know a smarter approach to moddeling something like this? Or how to solve my issue? I'm mainly a Nurb/Solid modeller, I'm using Blender to try and build out my skills in organic shapes so I'm still nooby.

Thanks!

This is the shape before subdivision

I marked Seam and Edge just to see if it would help

Artifacts when Subdivided

After moonboots comment I feel I wasn't clear on my design intent. Moonboots suggestion could work for some people but not in my instance.

Attempt 2 - To illustrate, I made a sketch in Fusion360 hit the Extrude command and exported that as an STL. The reason I'm trying to learn Blender is that this workflow is quick and works for me in some instances but it produces bad topography. So in Blender, I basically wanted to freehand draw a loop and extrude the fella. Fill the top and bottom surfaces. So I googled some more on Bezier curves and found how to use the Draw tool to freehand a curve, convert it to a mesh, extrude the Edges (not the vertices like the first time I tried). Select the top Edge Loop (Alt left click) which then gives me an option to fill the loop with a face (as opposed to a Grid Fill which produces problems). Now I can Shade Smooth the sides, and Edge Split the top edge, now my problem is that the top Edge Loop Face is now jagged. Is this fixable? When I - Add Modifier - Subdivision Surface, I can't work out why I get these tiger lines. My ultimate goal is to apply one shade to the top face and another shade to the side walls. Any tips, or help much appreciated.

Fusion Loop Fusion Extrude - Exported as STL Bad Imported Topology from Fusion Attempt 2 using Bezier Object Mode - Convert to Mesh Edit Mode - Select Edges and Extrude Fill Grid didnt work Selected Edge Loop allowed Face from Loop Jagged Top Edge Tiger Lines when Subdivided

$\endgroup$
1
  • $\begingroup$ You can use grid fill and play with span and offset to have better topology i.stack.imgur.com/BYgKK.gif $\endgroup$ – susu Dec 29 '20 at 18:27
1
$\begingroup$

You could do it this way, create a cubic shape, select the vertical edges:

enter image description here

Bevel:

enter image description here

Bevel the top and bottom edges:

enter image description here

Give it a Subdivision Surface modifier, it should work without artifacts:

enter image description here

$\endgroup$
3
  • $\begingroup$ Hi moonboots, thanks for your advice but in this instance it wouldn't solve my problem. I've added further clarity and a new attempt in my original post. If you have any ideas on how to improve I'd greatly appreciate the feedback! $\endgroup$ – David Horan Dec 29 '20 at 16:28
  • $\begingroup$ have you tried to simplify the top face? Use X > Limited Dissolve. Then bevel the top edge as I did. If it still doesn't work please share your file: blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Dec 29 '20 at 16:35
  • $\begingroup$ a quick way to fix would be to activate the Auto Smooth option in the Properties panel > Object Data > Normals $\endgroup$ – moonboots Dec 29 '20 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.