0
$\begingroup$

Blender Version: 2.91 (also 2.83)
GPU: Radeon RX 590 (with and without updated drivers)

Edit:

I stumbled upon the problem in another context which lead me to a way to recreate the glitch in a clean file:

  1. Open Default File (named General)
  2. Go to the material of the default cube (in Solid Mode)
  3. Under Viewport Display go to Color and set the Alpha to anything else than 1
  4. Add a new material

This creates the glitchy mesh seen in the image below.


Original Problem:

My viewport shows weird noise when I toggle x-ray mode only in solid view.

I had In Front (under Object Properties>Viewport Display) enabled for my mesh and after a lot of searching I found out that I can toggle the glitch by disabling that.

I cannot seem to recreate the glitch in a clean file though and I'm a bit afraid that something is broken in my file.

Things I tried before the "In Front" toggling:

  • deleting all vertex groups, materials, modifiers and all other objects in the file
  • switched from smooth to flat shading
  • cleared all marked edges
  • disabled auto-smooth
  • disabled all addons (and later used a clean install)

Changing the workspace resets the view but the glitch returns on toggling x-ray view.

At least when I export the mesh as an FBX file that seems to be glitch-free. Though that way I lose all my vertex groups.

Any ideas what is happening here?

x-ray mode glitch

$\endgroup$
8
  • $\begingroup$ Possibly a gpu problem, what is your gpu? Are your your drivers recently updated? $\endgroup$ – Timaroberts Dec 28 '20 at 23:18
  • $\begingroup$ I have a Radeon RX 590. After updating to latest drivers the glitch persists. I found a way to recreate the problem in a clean file though which involves the alpha channel of the material's viewport display setting. See my edit for detailed instructions. $\endgroup$ – Rayzorblade23 Dec 29 '20 at 0:09
  • 1
    $\begingroup$ This is likely part of the same AMD issue that has been affecting many users as of late, although some instances appear to look different, seems that the solution is the same... $\endgroup$ – Timaroberts Dec 29 '20 at 0:11
  • 2
  • 1
    $\begingroup$ No, don't delete the question. Write an answer with the info you found so far. Other users with similar issues will benefit from it. $\endgroup$ – susu Dec 29 '20 at 0:28
1
$\begingroup$

The glitch appears to be a driver issue with Radeon GPUs, especially with recent Blender versions. It is, as of yet, unresolved.

Link to the Bug Ticket:
https://developer.blender.org/T83022

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.