1
$\begingroup$

The "Outlines" feature of the Workbench render engine Properties / Render Properties / Options / Outline provides the expected results when rendering an animation from the UI Render / Render Animation (Ctrl + F12).

Using the command line (for something like blender -b myfile.blend -a with proper paths) on the same file gives a result which seems to completely ignore the outlines.

I tried this with multiple projects and Blender versions 2.80, 2.83, 2.91 & 2.92 alpha on a Linux Mint 19.3 environment, all with the same results. Searching online for bugs and/or implemented features returned nothing of relevance.

Any information on this? Maybe a setting I might have missed? Or a plug-in interfering?

$\endgroup$

1 Answer 1

0
$\begingroup$

I ran into the same problem today, and I found a solution by using the OpenGL render in a python script as such:

import bpy

# Most cited way of rendering via python:
#bpy.ops.render.render(animation=True)
# Produces no outline as by using blender -b myfile.blend -a


# Render with OpenGL:
bpy.ops.render.opengl(animation=True, view_context=False)
# Produces outlines as in the GUI

This can be used from a terminal like so:

blender myBlenderFile.blend --python myPythonScript.py 

Note however that I omitted the background flag -b due to that OpenGL does not support Blender running in the background. So depending on why you want to render from a terminal this solution might not be valid.

It worked well for me, however. Furthermore, it also resulted in a render speed increase as it seems like it better utilized multiple CPU threads.

"Standard" example where outline doesn't take

OpenGL example where outline works

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .