2
$\begingroup$

Take a look at the shadow cast by the leg on the sofa in the foreground. Even though the object is touching my shadowcaster surface, the bottom part of the leg casts no shadow.

Larger objects seem to cast shadows just fine, but table & chair legs pose a problem! Any suggestions as to how to approach this would be MUCH appreciated!

(This is some virtual staging for a real estate listing.) Sofa leg shadow doesn't reach the "ground"

enter image description here

$\endgroup$
2
  • $\begingroup$ have you enabled the Contact Shadows option of the light? $\endgroup$
    – moonboots
    Dec 28, 2020 at 17:15
  • $\begingroup$ Hey, that did it! An option I never even knew existed, "contact shadows"! Thank you! $\endgroup$ Dec 28, 2020 at 17:50

1 Answer 1

3
$\begingroup$

Enable the Shadow > Contact Shadows option of the light:

enter image description here

Also for the shadows quality, take a look at the Shadows in the Render panel (and increase the Sampling value):

enter image description here

$\endgroup$
3
  • $\begingroup$ Uploaded a new pic - much better shadows. Moved some lights around a bit, too. I knew how to tweak for shadow quality already, just needed that nudge toward "contact shadows". Always so many details to know in Blender - I'd be lost without this forum! $\endgroup$ Dec 28, 2020 at 18:03
  • $\begingroup$ yes Eevee gives headache sometimes, but I guess it's the price to pay ;) $\endgroup$
    – moonboots
    Dec 28, 2020 at 18:16
  • $\begingroup$ Yup! Now I need to fix that damn carpeting... :) $\endgroup$ Dec 28, 2020 at 18:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .