0
$\begingroup$

I decided to make an ice cube. It looked good on the default cube, but i knew that if i sculpt it, it would look a lot better. So i made another cube and i went into sculpting mode (It was my first time doing any sculpting, thought that its going to be easy). So after looking at what the different brushed do, i decided that to make what i need i will use the smooth brush on the edges of the cube. So after some work i made something i liked. But then on the next day, i saw these black things after i removed my bump map (it used a noise texture to give the ice some good look) - they were really weird.

enter image description here

enter image description here

I thought its something from the new roughness map i used, but after removing it from the roughness it was still there. Then in solid mode i saw the shading issues.

enter image description here

Here is the wireframe of the object: enter image description here

But after one subdivision modifier it was ok in solid, but still weird in rendered mode. I am using cpu rendering, cause my gpu gives Split render kernel errors. Here is my current node setup, just the glass.

enter image description here

$\endgroup$
2
  • $\begingroup$ Can you check Face Orientation view to see if some normals are flipped? The entire object surface should be colored blue in that view. $\endgroup$ – Allen Simpson Dec 28 '20 at 23:15
  • $\begingroup$ @AllenSimpson its all blue, also tried with backface culling, shows that its all fine. $\endgroup$ – TheMadTomato1209 Dec 29 '20 at 11:33
1
$\begingroup$

Simply add a Solidify Modifier and add thickness to the cube. Do bear in mind, this does essentially double the geometry calculated at render, so this might increase render time some.


This is the result from your file:

enter image description here

$\endgroup$
7
  • $\begingroup$ Man, that worked like a charm. Thank you! $\endgroup$ – TheMadTomato1209 Dec 28 '20 at 20:42
  • $\begingroup$ Actually, no. Now i see that its still pretty dead image. Even with solidify, a subdiv, and no auto smooth. I kind of think that it may be because its looking broken in solid mode as well, but i cant be too sure. Or i did something with the solidify modifier wrong? $\endgroup$ – TheMadTomato1209 Dec 28 '20 at 20:53
  • $\begingroup$ @TheMadTomato1209 nope, this is what it looks like here.. $\endgroup$ – Timaroberts Dec 28 '20 at 21:01
  • $\begingroup$ wow, this is weird. What version are you using? $\endgroup$ – TheMadTomato1209 Dec 28 '20 at 21:07
  • $\begingroup$ @TheMadTomato1209 the file was opened in 2.91.0 $\endgroup$ – Timaroberts Dec 28 '20 at 21:09
0
$\begingroup$

In The Properties > Object Data Properties > Normals >

Make sure 'Auto Smooth' is unchecked.

$\endgroup$
4
  • $\begingroup$ Just tried it, still the same. $\endgroup$ – TheMadTomato1209 Dec 28 '20 at 14:47
  • $\begingroup$ @TheMadTomato1209 Try disabling one Modifier at a time see which one changes the render. If there is no help try adding a wireframe image or send the Blend file. $\endgroup$ – Eric Huelin Dec 28 '20 at 14:54
  • $\begingroup$ There isnt much to disable, just one subdiv. So, here is the link: .blend file $\endgroup$ – TheMadTomato1209 Dec 28 '20 at 15:14
  • $\begingroup$ Hmm. Disabling autosmooth appeared to solve the problem for me. Maybe look again without subsurf? $\endgroup$ – Nate_Sycro27 Dec 28 '20 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.