1
$\begingroup$

I am new in Blender. I used Blender 2.91.0 under windows 10. I designed a basic cube in Onshape (kind of solidworks software) and exported as STL file. I imported this part in Blender, applied an image texture (in base color) but the texture is not displayed. If I do the same think with the startup cube already created in Blender, It works properly. See below some screenshots. Any ideas why the texture cannot be seen on STL imported part?

two cubes : STL and Blender

with texture applied


Following your recommendation, I applied an UV unwrapped and the texture is now displayed but how to have similar pattern that for the other cube?

UV unwrapped

$\endgroup$
6
  • 3
    $\begingroup$ STL Files don't have textures or shaders. $\endgroup$
    – Yohello 1
    Dec 26 '20 at 5:35
  • 1
    $\begingroup$ I know that the texture cannot be embedded in STL file that's why I imported first the STL part in Blender AND THEN I added an image texture on the part. The same image texture has been applied on the STL cube and also on the Blender created cube but only the latter works properly. why? $\endgroup$ Dec 26 '20 at 5:46
  • 1
    $\begingroup$ Have you uv unwrapped the object? $\endgroup$
    – Yohello 1
    Dec 26 '20 at 5:49
  • 1
    $\begingroup$ Following your recommendation, I applied an UV unwrapped and the texture is now display but how to have similar pattern that for the other cube? $\endgroup$ Dec 26 '20 at 5:57
  • $\begingroup$ I'm not sure how to do that, you should watch this video much better than I can explain youtube.com/watch?v=Y7M-B6xnaEM But at this point I suggest just exporting FBX or .blend with all external files packed. $\endgroup$
    – Yohello 1
    Dec 26 '20 at 6:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.