2
$\begingroup$

I used the modular tree add-on to make trees for a forest scene.

I want to scatter all the trees that I made around my scene via a hair particle system, but whenever I make the particle system, it only scatters the tree part and it doesn't take the leaves with it. In other words, whenever I make the particle system for my trees, the leaves do not show up on the trees. (see image below) enter image description here

As you can see from the image, the particle system does not render the leaves with the trees. Also, whenever I try to do the "render as collection", nothing even shows up, so I don't know what to do here.

I think it is probably because the leaves are parented to my tree object, and blender's particle system is not programmed to scatter parented objects. Normally that would be ok because I could just join the objects together, but because I used the modular tree addon, the leaves disappear whenever I join them.

The only other solution I have found so far is to convert each branch on the tree's particle system into their own individual meshes and then join them together, but that makes my computer incredibly laggy and I would really prefer not to do that, so if anyone has any creative solutions for this it would be much appreciated.

$\endgroup$
2
  • $\begingroup$ Could you add some images to help display your problem? $\endgroup$ – Nate_Sycro27 Dec 29 '20 at 0:09
  • $\begingroup$ ok, I added an image of what is happening, and I included the .blend file. Hopefully that sheds some more light on this. $\endgroup$ – ETHAN DAY Dec 29 '20 at 18:15
1
+50
$\begingroup$

After I examined the file and the way the addon works, I saw that the leaves are just vertices that emit hair particles. So, when you add a hair particle system to the plane, it just puts the tree trunk on, without the leaves.

After some trying I successfully joined the leaves and the trunk together. What I did is I first added a vertex group, which contained all the vertices that were in the object, emitting the leaves. Then I joined the leaves into the trunk, and then I added the particle system to the new object (since I added the leaves to the trunk, and not the opposite, the particle modifier was gone. I used the same particle system from the drop-down menu). I set the density of the system to appear from the vertex group, so now I had a whole object, emitting hair. but this still wont work, because its still hair.


The actual resolve

What you need to do is you have to convert all the hair objects into meshes. In the modifiers tab, just click convert. I would advise you to put the leaves object in a collection first, so that its easier to work after.

So, now you will have 3000 objects. Now, you need them all in one mesh. So, select all of them (if you listened to my tip and you putted them in a collection, RMB RMB on it > Select objects), then select the trunk last, so its the active object, and hit Ctrl + J Join Meshes . This is really hard for the computer to work with. Mine cant, actually. One tip, is to look away from the tree when joining, off course in blender, not irl. It makes it easier to actually do the calculations when it doesnt have to display it.

Then, you'll have the tree object. Now, when you put it as hair object, it will show all.

This may not be the best way to do it, but I cant think of another, currently.


New solution I found

So, I just found a new way to make it, and I even successfully rendered it.

What I did, is I used the tree I made by joining the leaves and the trunk together (See how I did it above). Then I set the hair instance object to be the new tree. So, now, if I convert all the trees into meshes, they will crash blender, because once they are meshes, their particle systems will work - i.e. it will have to show 1000 particle systems. That's why, before converting, disable the particle system on the tree model, so that you don't crash blender. Again, I advise you to use collections, because they make life so much easier.

After this, if you hide all trees except one and then you enable the system, you will see that it looks like a bush- really packed. This is because of the size difference between the instance object and the trees, that came out from the hair. So, first you need to copy the particle system onto that one tree, so that it won't effect the instance one. Then, you can change the size of the leaves, the amount etc.

After you are happy with the result, you can apply these particle settings to all trees. Make sure that before you do this, you hide the system from the viewport, to prevent blender from crashing. Then, you select all trees, then at last you select the one you were working on, Ctrl + L > Link modifiers. Since particle systems are modifiers, by linking them to other objects, you copy the particle systems as well.

And that's it! Now the trees are nice and done. Here is my render (its pretty low quality and its a screenshot, just for show off)

enter image description here

$\endgroup$
6
  • $\begingroup$ thank you, it is probably not the best solution but it is probably the simplest. It does make the file size a lot bigger when I make each leave its own mesh, but I'll just have to deal with that I guess. $\endgroup$ – ETHAN DAY Dec 30 '20 at 18:28
  • $\begingroup$ @ETHANDAY I found a new way to do it, ive added it to the answer $\endgroup$ – TheMadTomato1209 Jan 1 at 0:07
  • $\begingroup$ thanks! It took me a minute to figure out, but I think this solution works better, and is a lot less stressful on my PC. $\endgroup$ – ETHAN DAY Jan 1 at 17:09
  • $\begingroup$ @ETHANDAY yeah, sorry if i was too unclear. You also opened my eyes to this addon, im making some tree scenes right now. $\endgroup$ – TheMadTomato1209 Jan 1 at 19:53
  • $\begingroup$ yea, its a pretty cool addon isn't it? $\endgroup$ – ETHAN DAY Jan 2 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.